Jump to content
  • Sign in to follow this  

    Force map extractors to always build in release


    madmax
    • Status: accepted
      Main Category: Core / Mangos Daemon
      Sub-Category: Code Enhancement
      Version: 0.22 Milestone: 20 Priority: Normal
      Related to:
      Implemented Version: 0.20

    Force map extractors to always build in release

    I have a number of times now built the core in debug and not realised that it also builds the tools in debug aswell. This is a major issue as extracting maps in debug takes 12+ hours even on my 8core system.

    Set in release the map extractors only take 2 hours.

    I would like to propose that if the BuildEverything project is set to debug that the map extractors are still built in release. You should have to go into the configuration manager in VS to set them to debug mnaually if they really are needed.

    Sign in to follow this  


    User Feedback

    Recommended Comments

    Can Visual Studio not set the CMake parameters? I choose what I want to build in debug and release modes. Code::Blocks allows me to set my CMake parameters and I would think that Visual Studio could also. However, I do not know how it would be done.

    Share this comment


    Link to comment
    Share on other sites

    I think what max wants to happen is that movemap generator to not be allowed to be built in debug mode, or a big warning when run to explain to the user that running the debug version is a crazy idea.

    as an example:

    Release Movemaps for Zero: Execution time 45Min
    Debug Movemaps for Zero: Execution time 15 Hours

    I believe the extra time is due to the additional tracking done for debug in the recast library.

    We have had quite a few user reports that the movemap generator has taken a huge amount of time to run, when in fact it's because they built it in debug - rather than release

    Share this comment


    Link to comment
    Share on other sites

    Oh that makes sense. It is strange though, the one time I did this in Linux I do not remember it taking a long time. I will try this in Linux again and see what happens. I am only curious here. I agree that a warning should be issued when using a debug build since it takes so very long.

    Share this comment


    Link to comment
    Share on other sites


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

Contact Us

To contact us click here
You can also email us at [email protected]

Privacy Policy | Terms & Conditions

Repositories

The Link to the master list
of MaNGOS repositories:
Copyright © getMaNGOS. All rights Reserved.

This website is in no way associated with or endorsed by Blizzard Entertainment®
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use