Jump to content

Archived

This topic is now archived and is closed to further replies.

STWoW

4.0.1.13205 → 4.0.3.13287 is a stumper.

Recommended Posts

'lo all. I'm undergoing an attempt at a Cataclysm private server, and I am aware that ad.exe requires version 4.3.4 to function without crashing.

I started with the base 4.0.0.1 version, and I am currently sitting on version 4.0.1.13205, and I can't seem to find an executable as a patch for the next upgrade. Whatever version I find of the next patch is just an .MPQ patch file, and occasionally (But not always...?!) a .tfil file.

It is my understanding that the .tfil file goes in the main WoW directory, whereas the .MPQ file goes into the Updates folder. I actually have it in that folder and the Data folder just in case. The next step is apparently to use the Launcher.exe file.

That doesn't do anything useful, though. It just updates its own tools, then begins an optimization process, which somehow, somewhy, opens up a Mists of Pandaria launcher to optimize files.

So I'm really not sure how to proceed. Even WoW.exe crashes on opening right now due to improper string tables or something.

Do I have the wrong base version?

Share this post


Link to post
Share on other sites

Hey,

Download this - https://www.getmangos.eu/madmax/WorldofWarcraft4.3.4.zip

Extract to a folder.

Then download this - https://www.getmangos.eu/madmax/WoWRegeneration.exe

Extract that to the root of the WoW folder.

Run it selecting the 4.3.4 option and it will download all the files directly from blizzard. This will take awhile so you might have to leave it while it downloads.

Share this post


Link to post
Share on other sites

Very interesting! Thanks for that, definitely.

I'll see what happens. This will be an installation which I will attempt to run ad.exe (And the other vmap/map builders) from, and they didn't work on pre-packed Molten-WoW and Eternal-WoW builds, for example. Kept crashing on Expansion.mpq. So I'll see what happens with this one. It shouldn't, because it's straight from Blizz.

Share this post


Link to post
Share on other sites

Very interesting! Thanks for that, definitely.

I'll see what happens. This will be an installation which I will attempt to run ad.exe (And the other vmap/map builders) from, and they didn't work on pre-packed Molten-WoW and Eternal-WoW builds, for example. Kept crashing on Expansion.mpq. So I'll see what happens with this one. It shouldn't, because it's straight from Blizz.

We have used the same exact files for our own 4.3.4 test servers in the past ;)

Share this post


Link to post
Share on other sites

Really? Such as that torrent containing the Molten-WoW files? Not sure what "those exact same files are referencing;" mine or yours. My apologies.

Then my ad.exe must be broken or something. I've used it successfully years and years ago before, so why not now? I mean those only work on the server-compatible versions, like 1.12.1 and 2.4.3 and 3.3.5 and 4.3.4?

Share this post


Link to post
Share on other sites

Really? Such as that torrent containing the Molten-WoW files?

Then my ad.exe must be broken or something. I've used it successfully years and years ago before, so why not now? I mean those only work on the server-compatible versions, like 1.12.1 and 2.4.3 and 3.3.5 and 4.3.4?

No I mean we used the same exact files that I linked you!

Share this post


Link to post
Share on other sites

The links Max provided basically re-download the full client from blizzard. Can't get better than that :D

Share this post


Link to post
Share on other sites

Contact Us

To contact us click here
You can also email us at [email protected]

Privacy Policy | Terms & Conditions

Repositories

The Link to the master list
of MaNGOS repositories:
Copyright © getMaNGOS. All rights Reserved.

This website is in no way associated with or endorsed by Blizzard Entertainment®
×
×
  • Create New...