Jump to content

Search the Community

Showing results for tags '[Mangos One]'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Mangos Zero
    • Enhancement Requests (Zero)
    • Tasks (Zero)
  • Mangos One
    • Enhancement Requests (One)
    • Tasks (One)
  • Mangos Two
    • Enhancement Requests (Two)
    • Tasks (Two)
  • Mangos Three
    • Enhancement Requests (Three}
    • Tasks (Three)
  • Mangos Four
    • Enhancement Requests (Four)
    • Tasks (Four)
  • Mangos Five
    • Enhancement Requests (Five)
    • Tasks (Five)
  • Cross-Core
    • Bugs
    • Enhancement Requests
    • Tasks
    • Sub-Modules
    • Eluna
    • Linux
    • Windows
    • Archived Cross-Core/Other Reports
  • Others
    • Mangos VB
    • Mangos Sharp
    • Third Party Software
    • Website
  • Bug Tracker Archives (Resolved issues)
    • Archived Reports (Zero)(Resolved issues)
    • Archived Tasks (Zero)(Resolved issues)
    • Archived Reports (One)(Resolved issues)
    • Archived Tasks (One)(Resolved issues)
    • Archived Reports (Two)(Resolved issues)
    • Archived Tasks (Two)(Resolved issues)
    • Archived Reports (Three)(Resolved issues)
    • Archived Reports (Five)(Resolved issues)

Categories

  • Development Roadmap
  • Documentation
    • Installation Guides
    • Playerbot AI
    • Standards And Practices
  • Tutorials
    • Advanced
    • Contributing to Mangos
    • Debugging
  • Reference Information
    • ClientFiles
    • Database Info
    • DBC Files
    • Other
    • Packet Info
    • Server Files
    • Server Components

Forums

  • MaNGOS Information
    • Announcements & Releases
    • Covenant-WoW.com Website - Official Mangos Test Servers
  • Community Discussion Areas
    • Introduce Yourself
    • Community Cafe
    • Community Input
    • Community Projects
    • MaNGOS University
  • Community Help and Support
    • Peer to Peer Technical Support
    • Frequently Asked Questions
    • Resources
  • Development & Patch Submissions
    • Development
    • Patch Submissions
  • Eluna LUA Engine
    • Eluna Central
  • International Help & Support
    • International Boards
  • Archived
    • Main Archives
    • Archive of Pre-2012 Forum

Product Groups

There are no results to display.

Categories

  • Mangos Zero
  • Mangos One
  • Mangos Two
  • Mangos Three
  • Addons
    • Classic Addons
  • World Of Warcraft Patches
    • WoW Patches
    • The Burning Crusade Patches
    • Wrath of the Lich King
    • Client Tools Patchers

Blogs

  • getMaNGOS
  • DBC handling for mangos
  • The Road to Zero Release 21
  • Necrovoice's development blog.
  • What the Heck happened to Antz and MaNGOS in 2018 !!
  • Other Wow Emu Projects

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Core


Skype


Discord


Website URL


AIM


ICQ


Yahoo


Jabber


About Me


Gender


Location


Interests

Found 3 results

  1. Running ubuntu 16.04 with an apt-get of everything needed to compile. Compiles and installs as it should. Copy over game client and extract dbc/maps/vmaps/mmaps. End up with 39 locations for maps. If I did this on Windows (I tried it for sake of just copying the maps from there) and it has upwards of 89 locations. When I move the stuff over to the bin folder and run mangosd, mangosd reports that maps missing, everything in the 5xxxxxx.map range isn't there. On Windows, they are. I extracted them on Windows and copied them to the bin folder but am told by mangosd that the maps are incompatible with what I'm running. Even though the two things are the same version (least I imagine they are). Last map extracted is 4694735.map. I don't know what else to do, is there something I should put in the server/src/tools/Extractor_projects/map-extractor/System.cpp file for the map-extractor to see the other MPQs? I did have this client attach to a cmangos server and everything worked so I am inclined to believe that it isn't an incomplete version of the game. And the client is updated to 2.4.3 and detected as such. Thanks again for reading and any input is much appreciated. edit: I had cloned develop21 braches. That is what I wanted and thats what I ended up with. Solution in posts #3 and #4.
  2. when ever i try to use the dev build, i get this error when i attempt to compile it. also got the dev from: git clone https://github.com/mangosone/server -b develop21 --recursive This script builds the MaNGOS server. Options that can be used in order to configure the process: General: CMAKE_INSTALL_PREFIX Path where the server should be installed to CONF_DIR Path to the configs, can be absolute or relative. DEBUG Debug mode (strict compile, all warnings) ACE_USE_EXTERNAL Use external ACE BUILD_TOOLS Build the map/vmap/mmap extractors SOAP Enable remote access via SOAP Scripting engines: SCRIPT_LIB_ELUNA Compile with support for Eluna scripts SCRIPT_LIB_SD2 Compile with support for ScriptDev2 scripts # Modules: # PLAYERBOTS Enable Player Bots To set an option simply type -D<OPTION>=<VALUE> after 'cmake <srcs>'. Also, you can specify the generator with -G. see 'cmake --help' for more details For example: cmake .. -DDEBUG=1 -DCMAKE_INSTALL_PREFIX=/opt/mangosNote:OnUNIXsystems,CONF_DIRisrelativetothebinfolder. Detected 32-bit platform CMake Warning (dev) at cmake/FindGit.cmake:36 (find_program): Policy CMP0053 is not set: Simplify variable reference and escape sequence evaluation. Run "cmake --help-policy CMP0053" for policy details. Use the cmake_policy command to set the policy and suppress this warning. For input: '$ENV{ProgramFiles(x86)}/Git/bin' the old evaluation rules produce: 'C:\Program Files (x86)/Git/bin' but the new evaluation rules produce an error: Syntax error in cmake code at C:/Users/M91/Documents/GitHub/server/cmake/FindGit.cmake:40 when parsing string $ENV{ProgramFiles(x86)}/Git/bin Invalid character ('(') in a variable name: 'ProgramFiles' Using the old result for compatibility since the policy is not set. Call Stack (most recent call first): CMakeLists.txt:85 (find_package) This warning is for project developers. Use -Wno-dev to suppress it. Found OpenSSL library: optimized;SSL_EAY_RELEASE-NOTFOUND;LIB_EAY_RELEASE-NOTFOUND;debug;SSL_EAY_DEBUG-NOTFOUND;LIB_EAY_DEBUG-NOTFOUND Found OpenSSL headers: C:/OpenSSL-Win64/include Found MySQL library path: C:/wamp/bin/mysql/mysql5.6.17/lib Found MySQL library: C:/wamp/bin/mysql/mysql5.6.17/lib/libmysql.dll Found MySQL headers: C:/wamp/bin/mysql/mysql5.6.17/include MaNGOS-Core revision : 66310dc6ff847ad841a81369eb6b9420e1c15287 Install server to : C:/Program Files (x86)/MaNGOS Install configs to : C:/Program Files (x86)/MaNGOS/ Search configs from : binary directory (default) Support for SOAP : Yes Script engine Eluna : Yes (default) Script engine SD2 : Yes (default) Build tools : No Build in debug-mode : No (default) CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: LIB_EAY_DEBUG (ADVANCED) linked by target "realmd" in directory C:/Users/M91/Documents/GitHub/server/src/realmd linked by target "mangosd" in directory C:/Users/M91/Documents/GitHub/server/src/mangosd LIB_EAY_RELEASE (ADVANCED) linked by target "realmd" in directory C:/Users/M91/Documents/GitHub/server/src/realmd linked by target "mangosd" in directory C:/Users/M91/Documents/GitHub/server/src/mangosd SSL_EAY_DEBUG (ADVANCED) linked by target "realmd" in directory C:/Users/M91/Documents/GitHub/server/src/realmd linked by target "mangosd" in directory C:/Users/M91/Documents/GitHub/server/src/mangosd SSL_EAY_RELEASE (ADVANCED) linked by target "realmd" in directory C:/Users/M91/Documents/GitHub/server/src/realmd linked by target "mangosd" in directory C:/Users/M91/Documents/GitHub/server/src/mangosd Configuring incomplete, errors occurred! See also "C:/Users/M91/Documents/GitHub/server_build/CMakeFiles/CMakeOutput.log". only thing i can think of, its because i'm trying to do it with a 64Bit of OpenSSL, i'll try it with a 32Bit. also attaching the "CMakeOutput.log" had to rename it to .txt for it to upload. [ATTACH]238[/ATTACH] CMakeOutput.txt
  3. Hi! If anyone more traveled in these matters could give me some pointers I would be happy. I'm currently running an old repack Mangos for 2.4.3, v18 database I think and it's kinda wonky when I actually decided to play around. So I have been trying to get the v21 to work. For waaaay to many hours now, so asking for help. These are steps I have tried. I downloaded the v21 server files and extractor from this site, extracted and setup the config's is no biggie. After a few attempts with gitcloning the database, i notice when using git to downloaded the clone is missing several files, So I have now downloaded them manually and placed in the database folder for a complete database to install. Also found that the Database installer batchfile included had some errors regarding the updatesfolder so fixed those paths manually so the realm, character and world updates gets installed. there is a bunch of those updates sql files that gives errrors, I have no idea if this is supposed to be ok or not but for the characters DB update, these files gives error when installing: 21000_00_Release_021_Initial.sql and 21000_01_warden_action.sql gets an "Error 1146 at Line 2 : Table 'Realmd.character_db_version' doesn't exist" while Rel21_2_1_match_client_limits.sql *UPDATE FAILED* revision_refractor In the RealmDB update only 20150816_01_db_version.sql , Rel21_1_1_dbdocs_updates.sql and Rel21_1_2_dbdocs_update.sql are installed, the rest of the sql files are either skipped or failed. In the World updates folder, things are weird since there is a folder there thats supposed to be ran first, but if I do that mangosd.exe won't start since it complains about world_db table being wrong, and a quick look at the table reveals that all the updates in the worldfolder has had their names added to the db_version description, good for keeping track, but the server refuses to load if it's not exactly and only database 21,structure 1, content 0, revision_refractor, so to get the server to even start i need to run the files from the Rel20_to_Base_rel21Updates folder. (i also need to run the 20150816_01_db_version.sql in the realm updates too to get it to be what the realmd.exe is expecting. Now the server is startable, and playable but there is a bunch of errors related to Scriptdev2 and pretty much every castermob in instances is bugged and not following a player that moves out of LoS, so i expect i'm doing something horribly wrong. (i also tried to place the files from world/updates/rev21/Rel20_to_BaseRel21_Updates up into the rev21 and changed their names a bit so they'd get loaded in first. but that changed nothing. I apologize for the wall of text and probably incoherent rantings, but I'm stuck now and if anyone has some good ideas on how to get one up and running without all errors on the way, I'd be most thankful. /P
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use