Jump to content

configure "missing OpenSSL" solution

Recommended Posts

Actually ...

  • * All those steps should be already done by "autoreconf", no need to perform them manually
    * I have no problem building mangos on Debian testing (squeeze) 64bit with regular steps
    * True, the problem can appear on older systems

The correct solution for older systems is to install a newer OpenSSL libraries. Removing the check or going around it can lead to API errors, broken compiles, and other (even nasty) things.

Come on, typing one line of wget followed by one line of dpkg isn't that hard.

edit: I was referring to this post - http://getmangos.eu/community/viewtopic.php?id=13651&p=120520&viewfull=1#post120520

Link to comment
Share on other sites

  • 40 years later...


I had a little problem with OpenSSL with latest mangos revisions on a Debian 64bits system.

Here is a solution :

autoreconf --install --force
[color="red"]aclocal -I m4[/color] <- include m4 repertory fixes the issue with openSSL
automake --add-missing
automake src/bindings/ScriptDev2/Makefile

hope that helps.

Link to comment
Share on other sites

  • 3 weeks later...

There aren't any version of OpenSSL recent enough on those links.

I tried downloading the latest version on their website, and compiled it in my home directory. I then used the --with-openssl option to specify the good folder.

It didn't work.

Maybe I did something wrong though but the only working solution for me was the one above.

(and sorry for my english)

Link to comment
Share on other sites

  • 2 weeks later...
This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use