Jump to content

Problem with extracting maps (Mangos One)


randomkaos
 Share

Recommended Posts

Compiled from Mangos One git repository since yesterday. Only thing im having trouble with is extracting the maps from the game client. I get the following output from ad.exe:

Map & DBC Extractor

===================

Detected locale: enGB

Opening ./Data/enGB/locale-enGB.MPQ

Extracting dbc files...

Extracted 308 DBC files

Using locale: enGB

Opening ./Data/enGB/locale-enGB.MPQ

Extracting maps...

Read Map.dbc file... Done! (190 maps loaded)

Read AreaTable.dbc file...Done! (3045 areas loaded)

Read LiquidType.dbc file...Fatal error: Invalid LiquidType.dbc file format!

Game client version is: 2.4.3 (8606)

Mangos version is: MaNGOS One/0.12.1 (* * Revision 1307 - *) for Win32

Ive tried to recompile ad.exe from the source provided from the git pull, but still has the same problem. Looking in dbc folder it did manage to extract the LiquidType.dbc file, yet still bugs out when it gets to this point. If anyone can help me with this then it would be fantastic.

It's a fresh wow install. Classic wow installer (dvd) up to version 2.1.0, burning crusade (dvd) to 2.3.0, then patched up using various patches, all enGB locale to 2.4.3 (8606). Have i missed a patched or is this a problem with the ad.exe extractor? Im running attempting extraction on a Windows XP machine, so no administrator issues. Vmap extraction and building worked fine, as well dbc extraction. Just a problem with extracting the maps. Any help appreciated =]

Edit: src/game/SharedDefines.h does state that the client needs to be build 8606. Does anyone have a working ad.exe i can try or perhaps a little patch? ;p

Link to comment
Share on other sites

Map & DBC Extractor

===================

Usage:

ad(1).exe -[var] [value]

-i set input path

-o set output path

-e extract only MAP(1)/DBC(2) - standard: both(3)

-f height stored as int (less map size but lost some accuracy) 1 by default

Example: ad(1).exe -f 0 -i "c:\\games\\game"

ignore the (1) part, was a new compile of the exe. As you can see there is no -d option, but makes no difference anyway as there is only one version of the client installed on my system and thats 2.4.3 =[

Link to comment
Share on other sites

After slapping a few couts in the code, it fails at the following code when attempting to open the LiquidType, part of DBCFile::open().

if(header[0]!='W' || header[1]!='D' || header[2]!='B' || header[3]!='C')
      return false;

LiquidType.dbc is 9kb in size. Perhaps a bad dbc file extraction?

More info (added more couts):

Header[0]: ═

Header[1]: ═

Header[2]: ═

Header[3]: ═

Header[4]: ╠

LiquidType.dbc header thats being checked, seems like a bad file? ^^

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use