Jump to content

[SOLVED] MySQL issues


Recommended Posts

Hi,

So I've got Mangos set up and running. I've been playing on it for the last few days on my LAN while I've been waiting to get the internet set up in my apartment. Well, now i've got the internet set up and decided I wanted to make the server available across the internet. So, I went and updated my realmlist.wtf file with my dyndns hostname and added an entry to the realmlist table of the realmd database for the dyndns hostname as well. Then, I update the mangos and realmd conf files so that all the databaseInfo lines now point to the dyndns hostname.

Then I restart mangos annnnd... nothing. Fails to load. Can't establish a connection to the SQL database, error no. 2003. Ok, so next I:

- Forwarded port 3306 from the router to the MySQL server

- Added an exception for MySQL to the servers firewall

- disabled the servers firewall

- Ran a port scanner on the routers public IP for port 3306, result was that the port was open

- tried to telnet the loopback interface at port 3306, success

- tried to telnet the private IP (192.168.x.x) of the MySQL server at port 3306, success

- tried to telnet the routers public IP at port 3306, fails to connect

- checked the MySQL config file (my.ini), does not include bind-address or skip-networking

- added bind-address=0.0.0.0 to my.ini and restarted MySQL service, still fails to connect when using the public IP

So it seems like my SQL server is unreachable from outside my LAN. I made sure when going through the initial setup to allow remote root access. Anybody have any suggestions?

Link to comment
Share on other sites

The mysql user are usually bound to a ip aswell, but you do not have to access the mysql over internet, the only shit you have to change is in realmd. Conf if i remember correct, then the realmlist table in the database, i could explain further when i get a computer.

Best Regards

Carl Hjerpe

Link to comment
Share on other sites

thanks, the bit about the NAT loopback seems to have solved it. will have to try connecting from outside the LAN to be 100% certain though. And as for trying to connect to the SQL database over the public IP, well, to be honest that only came out after a couple hours of messing with all of this, and in hindsight didn't make a whole lot of sense.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use