Jump to content

OpenSSL Libraries Not Found


Guest manofwar95
 Share

Recommended Posts

I was trying to compile MaNGOS today, and upon configuring it I had an error, the OpenSSL Libraries could not be found

| CMake Error at cmake/FindOpenSSL.cmake:104 (message):

| Could not find OpenSSL libraries! Please install the library before

| continuing

| Call Stack (most recent call first):

| CMakeLists.txt:205 (find_package)

But I do have the OpenSSL Libraries installed, when I do "apt-get install openssl" it tells me I have them and that there is nothing to be installed/done.

Link to comment
Share on other sites

when I run where is openssl it displays the following, which one should I point to?

system-xenonproject:~# whereis openssl

openssl: /usr/bin/openssl /usr/share/man/man1/openssl.1ssl.gz

I downloaded OpenSSL from their website, configured and installed it but the same directories appeared /usr/bin/openssl is the executable not the libs/directory.

Link to comment
Share on other sites

I believe faramir was using the path he gave as merely an example.

Just replace his path with the path indicated by your Ubuntu installation.

While you're at it, get a real Linux. :P

...just kidding. :lol:

My sig is outdated, I am using debian now, also...

The following packages have unmet dependencies:

libcurl4-openssl-dev: Depends: libcurl3 (= 7.18.2-8lenny4) but 7.18.2-8lenny5 is to be installed

Depends: libssl-dev but it is not going to be installed

Link to comment
Share on other sites

@manofwar95: First I'd get rid of your ssl installation and afterwards install libssl and libssl-dev.

libssl-dev: Depends: libssl0.9.8 (= 0.9.8g-15+lenny13) but 0.9.8g-15+lenny14 is to be installed

Because this ^^^ is strange. Do you run lenny or did you install an old libssl? Debian is at 0.9.8o.

Hth

Skirnir

Link to comment
Share on other sites

@manofwar95: First I'd get rid of your ssl installation and afterwards install libssl and libssl-dev.
libssl-dev: Depends: libssl0.9.8 (= 0.9.8g-15+lenny13) but 0.9.8g-15+lenny14 is to be installed

Because this ^^^ is strange. Do you run lenny or did you install an old libssl? Debian is at 0.9.8o.

Hth

Skirnir

system-xenonproject:~# cat /etc/issue

Debian GNU/Linux 5.0 \\n \\l

I could just apt-get remove openssl, and try to update apt? Then try again. You just said that.. nvm >_<

HOWEVER:

Package libssl is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

E: Package libssl has no installation candidate

I think my best bet may to just install openSSL from the source code which I have tried but it didn't do anything, I ran it's "./configure" script, ran "make" and did "make install" but can't find any libraries or even tell that it did anything.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use