Jump to content

Cant connect to Realm


balcas
 Share

Recommended Posts

Hello guys. i have this problem im using Mangos server. and when i try to connect to my server i get to the Realm screen and then i cant connect to realms. MySQL is Working, Apache Working, Realm Working and World 1 Working. People from other places can connect to the Realm screen too u try to connect to world and thats it doesnt work.:*:

prob.jpg

its like this i press Okay

and then back to the same screen...

Link to comment
Share on other sites

Ahh, Realmloop. I had this when I first installed my server, turned out to be my realm database was referring the listed realms to the wrong ip address (was listed as 127.0.0.1 instead of my server's actual network address of 192.168.whatever.whatever...) Have you checked this?

Hmmm, perhaps I should explain a little further:

To find what your realms are being advertised as, you'll need to look at the realmlist table in your realmd database. I run a linux server so I fire up mysql like so:

[[email protected] ~]# mysql -u <whatever your database username is> -p

Enter password:

Welcome to the MySQL monitor.

mysql> use realmd

Database changed

mysql> SELECT * FROM realmlist ;

+----+--------+---------------+------+------+------------+----------+----------------------+------------+-------------+--------------+-----------------------------+------------------------------------------------------------------------------+

| id | name | address | port | icon | realmflags | timezone | allowedSecurityLevel | population | realmbuilds | site_enabled | ra_info | dbinfo |

+----+--------+---------------+------+------+------------+----------+----------------------+------------+-------------+--------------+-----------------------------+------------------------------------------------------------------------------+

| 1 | MaNGOS | 192.168.2.25 | 8085 | 1 | 0 | 3 | 0 | 0.02 | 12340 | 1 | type;port;username;password | localhost;3306;mangos;mangos;characters;localhost;3306;mangos;mangos;mangos; |

+----+--------+---------------+------+------+------------+----------+----------------------+------------+-------------+--------------+-----------------------------+------------------------------------------------------------------------------+

1 row in set (0.00 sec)

mysql>

I ended up hard setting the realm ip addresses in both mangosd.conf and realmd.conf as well as setting the ip address manually in the realmlist table of the realmd database by issuing

mysql> UPDATE realmlist SET address='192.168.2.25' WHERE id='1' ;

Query OK, 1 rows affected (0.00 sec)

Rows matched: 1 Changed: 1 Warnings: 0

mysql>

then fired up mangosd and realmd... Voila! Godmode Abounds!

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use