Jump to content
  • 0

LNK2019 error in EasyBuild



Good day!

I have had a mangosZero server for 2 years and wanted to try mangosOne now. I seem to be running into some trouble. I should mention, I'm a noob at all of this, I'm just doing as I'm told in this guide (which seems a bit outdated in places): 


Anyways, it all started with a bunch of MSB3073 errors in VS14 2015. I looked up what that might mean and found this post, saying it had to do with a copy failing. Solution: copy manually.

Then I noticed that I couldn't find certain files anywhere. I deleted the build and install folders, and ran Easy Build again. Then I saw that Easy Build finished with a bunch of errors which I probably missed the first time. Turns out the problem was there before I got to the Visual Studio step.

As I said above, I follow the guide. I leave all settings on default in Easy Build, except I have to set the Visual Studio version manually to VS14 2015, it tries to use VS15 2017 which obviously can't be found. I'll attach the Easy Build log file.


I'm not sure what other info is needed to solve this, I'll start by listing all the software versions I'm using:

  • Windows 7 64bit (running in a Hyper-V as a test, the dedicated machine is still running mangosZero for now)
  • Git 64bit
  • Visual Studio 14 2015 community
  • Cmake 3.11.3 64bit
  • OpenSSL 1.0.2o-32, 1.0.2o-64, 1.1.0h-32, 1.1.0h-64
  • MySQL 64bit

If anything else is needed let me know!

EB log.txt

Link to comment
Share on other sites

3 answers to this question

Recommended Posts


Just to check, I cloned the Zero and Two server and database as well. I tried to run their respective Easy Builds, but it came up with pretty much the same errors.

I uninstalled OpenSSL 1.1.0h and reinstalled 1.0.2o. The log still had some C**** (C4477, C4313, etc) warnings in it, but the whole process took longer, and now VS2015 also managed to finish, and the Install folder actually had more in it than just a single DLL file. I don't have time to finish the building now (it's 4 am here), but so far it would seem OpenSSL 1.1.0h is not usable yet?


btw I thought I read somewhere that I could install all versions next to each other, like you can have .net 3.5 and .net 4.5 etc. Turns out 1.1.0 overwrites 1.0.2. I guess you're only supposed to install the 32 and 64 bit versions next to each other.

Link to comment
Share on other sites

It seems that you have chosen to compile in 32 bit but cmake has chosen 64 bit openssl.
Maybe easybuild has a problem or maybe you should clear cmake cache or something like that. Or maybe easybuild allows you to choose the library to use and you must choose 32 bit.

In general you should probably always prefer to use 64 bit though as that allows the server to use more ram for example.
All dependencies must be 32 bit if you are compiling as 32 bit.

Link to comment
Share on other sites

Thanks for your reply!

I know about the memory restrictions and was aiming to compile in 64 bit. I have not knowingly chosen to compile in 32 bit anywhere, where could I have made this mistake?

I checked Easy Build quickly..
When I scan, it detects 64bit correctly (everything is green apart from MySQL server 32bit)
Clicking Build Options, it only shows OS Version Build: Win64 (no other options in the dropdown)

The only thing I noticed is that after the scan it says VS2017 is one of the available compilers (along with VS2013 and VS2015), while I'm fairly certain I installed VS2015. On the Build Options screen I use the dropdown to set it to VS2015 manually, and then it'll start. If I don't, it shows the following:

Cmake Error at CMakeLists.txt:20 (project):

	Visual Studio 15 2017 Win64

 could not find any instance of Visual Studio

Other than picking the VS2015 compiler I didn't change anything about that screen.
Running it with VS2015 generates the result as in the log file in my original post.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use