Jump to content
  • 0

Odd fix to a realm loop issue



so, i never encountered this much issue with realm loops in the past when running private servers before but here is an odd one. plus a work around.

Install done on Linux Mint 20.3

so i had installed a clean server for vanilla and was able to locally log in, I had configed my db to allow external IP connections to my server for my buddy all and fine he can connect now. In doing this i blocked myself from connecting locally (as the server is on the computer i am playing on and using WINE to run WoW). i set all my configs back to normal but hey i still was unable to connect locally, odd... after hours of different fixes and combos of IP address' and walkthroughs no dice.


I started just fiddling around with the Config.wtf in the WTF folder in the WoW client, i edited the SET RealmName "" and removed the server it had listed there. I proceed to boot up WoW and log in as usual and to my suprise i was able to log in to the server just fine. now once i disconnect and try to reconnect again i am unable to until i close WoW and delete that entry in my config again, which then i am able to connect again.


This has to be the oddest work around i have found worked by just messing around with the config.


hope this helps anyone else here as this work around can help you connect and play locally with external connections until you move the server to a VM or a dedicated system. 


and yes i had set my external IP and address in the DB as local IP yet it would not allow me to connect until i removed the server name from my config file.


the odd things we stumble on...

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hello @sscultima.

Thanks for posting here. Sorry for the late response. If you want there is also an active Discord chat : https://discord.gg/HeRQHhjK

You said 


I had configed my db to allow external IP connections to my server for my buddy

That's a first wrong thing you've done. Basically the MySQL/mariaDB (depending on what you choosed) database should only receive localhost connections since it is the MaNGOS daemons which require a connection to the DB... not your "buddies" ;).

In the realmlist in your database, you should have set the IP adress to your global WAN adress that your ISP provides to you.

The local address should be the LAN adress of your hosting PC.

You buddies can set the external address and you can set the local one since you are at home ;).

In the mangosd.conf file you should have set "BindIP" to

Feel free to reach us on our Discord to discuss further about your issue.

Best regards,


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use