Jump to content
  • 0

MangosTwo - Windows 10 - Unable to run mangos and realmd programs - Error 0xc0150002


Draz8

Question

Hi everyone! 🫡

After several days of trying to find a solution to my problem, without success, I would like to appeal to you because I think I have tried all the recommendations I could gather.

 

Problem:

I am unable to run the programs realmd.exe and mangosd.exe.

The following error message appears:

The application was unable to start correctly (0xc0150002).

I have the impression that it comes from a Microsoft framework like Visual Studio or .NET, so I installed it all.

 

Context:

  1. I followed step-by-step the getMaNGOS guide.
  2. I run my program from a newly created and updated Windows 10.
  3. I generate the build files with MaNGOS_EasyBuild, all prerequisites have been validated.
  4. From the MANGOS Solution, I compiled the server files with Visual studio 2022 with no errors.

 

I have installed all the following Visual studio C++ Redistributable:

Spoiler

image.png.2476987cd7854c4d47f0abcaa986eaf0.png

.NET:

  • .NET 3.5 (2.0 & 3.0)
  • .NET 4.5
  • .NET 4.8

They are activated in the Windows features :

image.png.a02541bf36f1023a2ed4570d27f973d7.png

 

I have run all the following restore commands:

  • sfc /scannow
  • dism /online /cleanup-image /restorehealth

I also used Microsoft's .NET repair tool.

 

Despite all this, I get the same error message and I think I've exhausted all the sources that mentioned this error.

 

Hopefully, one of you will have an idea 🙂

I'm going back to hunting in the meantime.

 

Thank you in advance for taking the time to read my message.

Draz

 

Edited by Draz8
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Good evening!

Was this the guide that you tried to follow: 

 Make sure you read through this sub-post VERY carefully as a missed step can result in failure: 

If so, try deleting the server files and re-cloning them and take another shot at it from scratch.

Link to comment
Share on other sites

  • 0

Hi Fyre!

First of all, thank you for your reply 🤜.

 

In fact, I had finally found a copy of the VS2015 installer, which is no longer available for download from the Microsoft website.

During installation, the VS2015 installer returned a missing package and I had to "skip" each time. As a result, I concluded that it was no longer possible to proceed with VS2015.

So I downloaded VS2022 following a comment confirming that it worked and selected all the C++ and WEB development modules, but that doesn't seem to be enough.

I'm going to look for another VS2015 installer in the hope that it will have better luck finding the desired packages and report back in case other people encounter the same problem one day. 

 

Thanks,

Draz

Link to comment
Share on other sites

  • 0

Hello everyone,

I finally managed to run mangosd and realmd!

I found a VS2015 ISO on StakeOverflow that worked much better than the first executable I had.

Here are the extra steps I did to stop getting the 0xc0150002 error:
- Installing VS2015 with Visual C++
- Retrieve the libcrypto-1_1-x64.dll file from the OpenSSL installation directory and copy it to the Windows/System32 directory.
- OpenSSL installation file in root of C drive

I hope this helps those who have the same problem as me!

Draz

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use