Jump to content

.maps/0004331.map is non-compatible

Recommended Posts

  • 40 years later...

I can not start this server for the life of me. I keep gettng to this part and it is stuck. First off, my VMaps are all disabled (they read 0)

Second. I have made sure that I used the most recent ad.exe...

Currently I am using UDB 0.12.0 (388) for MaNGOS 9582 with SD2 for rev. 1639

I think I have used every ad.exe I could find.

WOW is updated and everything seems to be correct besides this.

I have been over it abot 50 times...

Please help


I did have the newest database to the same point, but I was trying to just backfit it to an earlier version to work...

Link to comment
Share on other sites

Thank you very much. It worked. I was using the sticky installation guide. Maybe guys whould merge the two? I done what you had said to do already, but I used a bunch of different ad.exe's and I forgot to ensure that the one I downloaded with MaNGOS was used. I am glad to say after a couple of weeks of learning I have my very own server up and running. Thank you

Thank you all very much for your support and work on these projects. I am going to donate for all of your support on this.

Link to comment
Share on other sites

I cant understand... I am having the same problem:

My mangos/NEWS :

Version 0.16

* Under discussion.

* OpenSSL lib upgrade to OpenSSL 1.0.0.

* Upgrade to client version 3.3.3a (build 11723).

My mangosd.conf:

RealmID = 1

DataDir = "/opt/mangos/data/"

LogsDir = ""

my directories struture:

[mangos]# ls

Char.log bin lib svnudb

DBErrors.log data mangos udb

Server.log etc scriptdev2 zips

I am using mangos latest verstion and udb latest version as well.

the debbug window shows me that when I try to start mangos-worldd:

Connected to MySQL database at

MySQL client library: 5.0.77

MySQL server ver: 5.0.77


Realm running as realm ID 1

Using World DB: UDB 0.12.0 (389) for MaNGOS 9630 with SD2 SQL for rev. 1656

Using creature EventAI: ACID 3.0.4 - Final Release for Mangos (3.3.2 Client)

Using DataDir /opt/mangos/data/

WORLD: VMap support included. LineOfSight:0, getHeight:0

WORLD: VMap data directory is: /opt/mangos/data/vmaps

WORLD: VMap config keys are: vmap.enableLOS, vmap.enableHeight, vmap.ignoreMapIds, vmap.ignoreSpellIds

Map file '/opt/mangos/data/maps/0004331.map' is non-compatible version (outdated?). Please, create new using ad.exe program.

Correct *.map files not found in path '/opt/mangos/data/maps' or *.vmap/*vmdir files in '/opt/mangos/data/vmaps'. Please place *.map/*.vmap/*.vmdir files in appropriate directories or correct the DataDir value in the mangosd.conf file.

thanks in advance!!

Link to comment
Share on other sites

i am about to give up. Jesus! it was so easy before... now, I simply can not!

My wow is 3.3.3(11723) mac version. i use ad.exe (with crossover) from the last mangos/contrib.

put the map and dbc folder inside /opt/mangos/bin (tried to leave them in /opt/mangos as well)

nothing appears to solve that problem. so sad.

at the DataDir conf, I tried to put the full path, tried tu leave it blank, put a dot "." and nothing! it keeps telling me that 0004331.map is outdated.

tried with and withou vmaps and so... nothing, nothing appears to help.

thank you mikex for ur support... i am sure that there is trick somewhere.

thank you

Link to comment
Share on other sites

i had this problem some time ago and i found that i was using an outdated ad.exe...but i see that you're using latest mangos source. have you tried to move your mangos dir to another place? try to put it in C:\\Mangos and see what happens...or wait for a new commit and try to re-download the whole source...

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use