Jump to content

[Bug] implemented spell 44875 (Complete Raptor Captor) does not work as it should be

Guest aragorn

Recommended Posts

Mangos: 10258

UDB: 392

SD2: 1749

What it does: already implemented in spelleffects in effectDummy:

case 44875: // Complete Raptor Capture


if (!unitTarget || unitTarget->GetTypeId() != TYPEID_UNIT)


Creature* creatureTarget = (Creature*)unitTarget;


//cast spell Raptor Capture Credit

m_caster->CastSpell(m_caster, 42337, true,NULL);

this for some reason does not work, it will not give a Invis Raptor Credit



How it should work: dummy spell 44875 should cast spell 42337 (Raptor captor credit), this should give player an Invis Raptor Credit, but it doesn't

I do not know why implementation does not work

Link to comment
Share on other sites

db is fine: ReqCreatureOrGold1 = 23727

My guess is that the spell being cast 42337 that should create an Invis Raptor Credit (23727) does not work properly.

spell 42337 has 134 (effectKillCredit) as spellEffect with miscValue of 23727

I've set a debug statement in my local copy in method effectKillCredit (spellEffects.cpp) but I never see any log statement, It never gets there.

Link to comment
Share on other sites

I've tried something:

when I run the command .cast 42337 triggered then the spell works I get a Kill Credit

When I use the Item Sturdy Rope (to capture a raptor) the spell 42337 is being cast but I don't get a kill credit

Is it possible the code uses a wrong target (It must be the player)

Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use