Jump to content

Items sent in mail disappearing


Guest pubgrub
 Share

Recommended Posts

Mangos Version: 11618

Custom Patches: PlayerBot (by blueboy)

SD2: Revision 2222

DB: UDB 0.12.1 (401)

Problem:

Sometimes received mails don't contain any items that have been sent in that mail.

Server.log shows:

2011-06-15 19:53:50 ERROR:Item #2784 have broken data in `data` field. Can't be loaded.

2011-06-15 19:53:50 ERROR:Player::_LoadMailedItems - Item in mail (32) doesn't exist !!!! - item guid: 2784, deleted from mail 

2011-06-15 19:53:50 ERROR:Item #2857 have broken data in `data` field. Can't be loaded. 

2011-06-15 19:53:50 ERROR:Player::_LoadMailedItems - Item in mail (32) doesn't exist !!!! - item guid: 2857, deleted from mail

Mysql query of several items show i.e.:

mysql> select * from item_instance where guid = 742; 
+------+------------+------------------------------------------------------------------------------------------------------------------------------------------------------------------+------+ 
| guid | owner_guid | data | text | 
+------+------------+------------------------------------------------------------------------------------------------------------------------------------------------------------------+------+ 
| 742 | 7 | 742 1191182336 3 7288 1065353216 0 4 0 4 0 0 0 0 0 1 0 4294967295 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 | 
| +------+------------+------------------------------------------------------------------------------------------------------------------------------------------------------------------+------+
1 row in set (0.00 sec)

mysql> select * from item_instance where guid = 2784;
+------+------------+------------------------------------------------------------------------------------------+------+
| guid | owner_guid | data | text | +------+------------+------------------------------------------------------------------------------------------+------+ 
| 2784 | 1 | 2784119118233632589106535321601040000010000000000000000000000000000000000000000000000000 |
| +------+------------+------------------------------------------------------------------------------------------+------+
1 row in set (0.00 sec)

When I tried to pick the second mail, I got no item. Looks like the data field is lacking spaces.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use