Jump to content

[Solved]Mangosd can't connect with my MySQL server


Recommended Posts

Hi all!

I'm trying to set up a World Of Warcraft private server with ManGOS. I've read many of the stickies and many of the wiki pages, but I can't get it to work. I primarily used the installation guide for Windows in this subforum.

My mangosd can't connect to my MySQL server. The MySQL server is running, and has an account called 'mangos' with the default password 'mangos'. ( I don't know if I should change the password, I have configured my MySQL server to not allow remote queries so I don't know if it matters ). My realmd can't connect to it either. The default user-password pair are still configured in the configuration files of both.

The version of my MySQL server is 5.1, that of my Mangosd and Realmd is 0.17.0-DEV.

I hope someone can help. I'm a complete newbie in the World of Warcraft server ( and in general :P ) world.

Thanks in advance,

Joshua.

Link to comment
Share on other sites

  • 41 years later...

1st change your config files to use the name and password you've set up for MySql (mangos,mangos). No if your MySql is on the same machine as your trying to run Mangos from you can leave the remote turned off...Now you'll need to set the .conf for mangos, realm, and ScriptDev2 .conf and in mangos.conf there are multiple lines you need to do this with...example:

LoginDatabaseInfo = "127.0.0.1;3306;mangos;mangos;realmd"

WorldDatabaseInfo = "127.0.0.1;3306;mangos;mangos;mangos"

CharacterDatabaseInfo = "127.0.0.1;3306;mangos;mangos;characters"

also when you first installed MySql there was an acount you set up with root as the username and you chose a password....you can also use these in the configs, example

LoginDatabaseInfo = "127.0.0.1;3306;root;yourpassword;realmd"

WorldDatabaseInfo = "127.0.0.1;3306;root;yourpassword;mangos"

CharacterDatabaseInfo = "127.0.0.1;3306;root;yourpassword;characters"

I hope this helps.

Link to comment
Share on other sites

  • 3 weeks later...
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use