Jump to content

mangosd crashes when entering the world


Auntie Mangos
 Share

Recommended Posts

  • 41 years later...

Hello!

(sorry for my bad english)

When i select one of my existing characters and push the Enter World button I always get this message: "You have disconnected from the server." Because mangosd.exe crashes at this point. Same result with the new created characters too.

Windows XP sp3 32bit (localhost)

Mangos 11836 (compiled in Visual C++ 2010 Express)

+ scriptdev2 2319 + acid 3.0.9 + UDB 0.12.2

size of mangosd.exe: 6.221.824 Bytes ~ 5,93 MB

Crash log (after I accept a new character):

Revision: * * 11836 *

Date 4:11:2011. Time 7:7

//=====================================================

*** Hardware ***

Processor: AMD Athlon

Number Of Processors: 1

Physical Memory: 2096624 KB (Available: 1297488 KB)

Commit Charge Limit: 2991600 KB

*** Operation System ***

Microsoft Windows XP Professional Szervizcsomag 3 (Version 5.1, Build 2600)

//=====================================================

Exception code: C000001D ILLEGAL_INSTRUCTION

Fault address: 0068A6EA 01:002896EA D:\\MaNGOS\\mangosd.exe

Registers:

EAX:00000001

EBX:73477900

ECX:C17E04A2

EDX:00000044

ESI:78014000

EDI:00000004

CS:EIP:001B:0068A6EA

SS:ESP:0023:077499A0 EBP:077499BC

DS:0023 ES:0023 FS:003B GS:0000

Flags:00010246

Call stack:

Address Frame Function SourceFile

0068A6EA 00000000 [email protected]@@[email protected]+5A

00680322 00000000 [email protected]@@[email protected]+32

006804E7 00000000 [email protected]@@[email protected]+27

004CC348 00000000 [email protected]@@[email protected]@@Z+6A8

00755B55 00000000 [email protected]@@[email protected]@[email protected]@[email protected]@@Z+2FC5

00756B5C 00000000 [email protected]@@[email protected]@[email protected]@[email protected]@@Z+3FCC

007571AB 00000000 [email protected]@@[email protected]@[email protected]@[email protected]@@Z+461B

00762E94 00000000 [email protected]@@[email protected]@[email protected]@[email protected]@@Z+10304

004BF18D 00000000 [email protected]@@[email protected]@@[email protected]@[email protected]@[email protected]@[email protected]+1ED

004C4002 00000000 [email protected]@@[email protected][email protected]@[email protected]@[email protected]@[email protected]@@Z+102

0055DC32 00000000 [email protected]@@[email protected]+7F2

0056099D 00000000 [email protected]@@QAEXXZ+BD

0056A5B3 00000000 [email protected]@@[email protected][email protected]@[email protected]@[email protected]@[email protected]@[email protected]@[email protected]+653

00832771 00000000 [email protected]@@[email protected]@@Z+761

00605061 00000000 [email protected]@@[email protected]@[email protected]@@Z+21

0060A481 00000000 [email protected]@@[email protected]@@Z+181

00487BF4 00000000 [email protected]@@[email protected]+4E34

00489BD2 00000000 [email protected]@@[email protected]+6E12

004551C2 00000000 [email protected]@[email protected]@@Z+4E02

00A57064 00000000 [email protected][email protected]@UAEKXZ+74

78AFC6DE 00000000 _endthreadex+3A

78AFC788 00000000 _endthreadex+E4

7C80B713 00000000 GetModuleFileNameA+1B4

Call stack:

Address Frame Function SourceFile

7C90E4F4 00000000 KiFastSystemCallRet+0

7C802542 00000000 WaitForSingleObject+12

00A0AB83 00000000 [email protected]@[email protected]+363

00A7DF91 00000000 [email protected][email protected]@[email protected]@@Z+1E1

00A79D6F 00000000 [email protected][email protected]@UAEHXZ+F

0045083A 00000000 [email protected]@[email protected]@@Z+47A

004573D9 00000000 [email protected]@@[email protected]+699

7C817067 00000000 RegisterWaitForInputIdle+49

Call stack:

Address Frame Function SourceFile

7C90E4F4 00000000 KiFastSystemCallRet+0

7C802455 00000000 Sleep+F

00466DAE 00000000 [email protected]@[email protected][email protected]+32E

004683BD 00000000 [email protected]@[email protected][email protected]+193D

00A57064 00000000 [email protected][email protected]@UAEKXZ+74

78AFC6DE 00000000 _endthreadex+3A

78AFC788 00000000 _endthreadex+E4

7C80B713 00000000 GetModuleFileNameA+1B4

Call stack:

Address Frame Function SourceFile

7C90E4F4 00000000 KiFastSystemCallRet+0

7C802455 00000000 Sleep+F

00466DAE 00000000 [email protected]@[email protected][email protected]+32E

004683BD 00000000 [email protected]@[email protected][email protected]+193D

00A57064 00000000 [email protected][email protected]@UAEKXZ+74

78AFC6DE 00000000 _endthreadex+3A

78AFC788 00000000 _endthreadex+E4

7C80B713 00000000 GetModuleFileNameA+1B4

Call stack:

Address Frame Function SourceFile

7C90E4F4 00000000 KiFastSystemCallRet+0

7C802455 00000000 Sleep+F

00466DAE 00000000 [email protected]@[email protected][email protected]+32E

004683BD 00000000 [email protected]@[email protected][email protected]+193D

00A57064 00000000 [email protected][email protected]@UAEKXZ+74

78AFC6DE 00000000 _endthreadex+3A

78AFC788 00000000 _endthreadex+E4

7C80B713 00000000 GetModuleFileNameA+1B4

Call stack:

Address Frame Function SourceFile

7C90E4F4 00000000 KiFastSystemCallRet+0

07748A24 00000000 0000:00000000

354C15FF 00000000

My previous server works fine:

Windows XP sp3 32bit (localhost)

MaNGOS 10553 (compiled in Visual C++ 2005 sp1)

+ scriptdev2 1833 + acid 3.0.5 + Udb 0.12.1 (update 393)

It's so bad there isn't mangosdVC80.sln anymore.

Do you have any ideas? Please help!

Link to comment
Share on other sites

I don't use any modifications. First I tried this (in order) without my old characters & realmd tables:

characters table:

- characters.sql

mangos table:

- UDB_0.12.2_mangos_11792_sd2_2279.sql

- mangos updates: 11807_01, 11813_01, 11827_01, 11831_01, 11831_02

- mangos_scriptname_full.sql

- (there are no sd2 updates, so i skipped this step)

- 3.0.9_acid.sql

realmd table:

- realmd.sql

scriptdev2 table:

- scriptdev2_create_structure_mysql.sql

- scriptdev2_script_full.sql

Is this good, or wrong?

Link to comment
Share on other sites

I had exactly the same problem with the first mangos I compiled. For me it was an issue with unsupported instructions for the CPU. (Exception code: C000001D ILLEGAL_INSTRUCTION)

Mangos uses SSE and SSE2 instructions, I was using a CPU that didn't support SSE2 (a Pentium 3 to be exact, but the same problem should exist in Athlon XP and earlier AMD CPU's)

Setting the compiler to only use SSE, and not SSE2 instructions didn't help, the same problem continued to exist, but after I set the compiler to not use SSE at all it did work.

It seems more people have had this same problem, but it is consistently misinterpreted as a script problem or a database problem, but it is actually an instruction-set problem, set your compiler to not use SSE and SSE2, and it should work fine.

Link to comment
Share on other sites

I would like to thank all of you for your responses.

I want to try that SSE thing. My CPU is an AMD Athlon xp (Barton) 2800+. Supports these: x86, MMX, 3DNow! and SSE. But not SSE2.

These Visual C++ (like 2010) Express editions are very limited. Compiler options aren't accessible. However I have the Visual Studio 2005 Professional, and I found it:

/Property Pages/Configuration Properties/C & C++/Code Generation/

Enable Enhanced Instruction Set = [not set | SSE | SSE 2]

But i think mangos doesn't support C++ 8.0 anymore (i can't find mangosdvc80.sln). So must I get a Visual Studio 2010 Professional edition to compile mangos project?

Link to comment
Share on other sites

I cannot tell you if this option exists on VC100 express or not, maybe it is just hidden.

For VC2005 you can try the following:

* try to use cmake to create project files (it should work)

* revert the (recentish) commit where zergtmn removed vc80 support, then you only need to manually add support for creature_linking

Link to comment
Share on other sites

revert the (recentish) commit where zergtmn removed vc80 support, then you only need to manually add support for creature_linking

Please don't say things like this to me, I'm not clever as you :)

Finally with all your helps, this solved my problem:

there are 11 projects in mangos, these uses SSE:

framework

g3dlite

game

mangosd

realmd

shared

zlib

in Visual Studio 2010 express:

(Context menu)/Properties/Configuration Properties/C & C++/Code Generation/

Enable Enhanced Instruction Set = [not set | SSE | SSE 2]

need disable each one individually before compile

I receive this strange message:

ERROR:SESSION: received not allowed opcode CMSG_LFG_GET_STATUS (0x0296)

But it seems to be working now: NO CRASH.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use