Jump to content
  • 0

Problems connecting over WAN


Deathomen

Question

I seem to be having a bit of trouble with my newly configured server. First I'll give you a little background so you know my experience level and what suggestions would/would not be helpful. I apologize in advance for the novel...

I've been in and out of the emulation scene for about 5-6 years now. I originally started out using a MaNGOS repack when I was a newbie, then shifted over to an Antrix server when I started compiling and configuring my own. I followed the Antrix path up through ArcEmu but left the scene about a year and a half ago, coming back for very brief occasions since then. I assisted with several database projects and even ran one of my own during the peak of my involvement. I've also created several basic C++ scripts and core modifications. I'm generally the person providing assistance for those who are having problems ranging anywhere from simple to mid/early advanced issues. Since I don't have a very strong C++ background experience I'm not able to answer or handle some of the more intricate core modification questions, but I've always had a drive to expand my knowledge. With that being said, I'm returning to MaNGOS for the first time in quite a long time.

In a general sense, I should be able to configure a MaNGOS server using the experience I have from previously - and for the most part I've done just that. I got everything installed and compiled the MaNGOS and ScriptDev2 files with no problem. I've been able to extract the required client files and get my server running and accessible on my local machine. I've also been able to configure the server to be accessed by other machines on my LAN, and I have a dedicated box that I run the server on. The problem comes in when I try to access the server from a machine outside my current LAN, such as when my brother tries to connect to the server from my parents' house. Here's what I've done to make this happen..

After getting the server working on my LAN I adjusted the realmlist table to my external IP address. I then forwarded ports 80, 8085, 8086 (second realm), and 3724 to my server box which has a static IP address. Additionally, I've placed the machine's IP address in the DMZ on my router. I checked through the config files for each server but didn't see anything that needed to be modified for the server to be accessed publicly. When trying to connect from my brother's machine the client gets stuck at "Connecting" for a minute and then returns a "Login Server Down" message. After getting thoroughly irritated with this issue I decided to install Hamachi on the three machines (server machine, personal machine on same LAN and brother's machine at a different location). I modified the Realmlist table to set my hamachi IP address as the realm's IP and attempted to connect again, but also failed. I am still able to access the server on my personal machine while connected to Hamachi, however.

This is a fresh install of Windows 7 Professional. I reinstalled to make sure that no software was conflicting with the server. This machine is literally ONLY running the MaNGOS servers. I would appreciate it if someone could point me in the right direction, or ask me some questions to which I would provide answers to lead to the resolution of this issue. It's quite irritating, and I don't feel that it should be this difficult. This is likely just some stupidly easy problem that I'm over-complicating and not seeing, so please be gentle when beating me over the head of my stupidity.

Link to comment
Share on other sites

13 answers to this question

Recommended Posts

1. Did you setting up your brandmauer? I don't know how in Windows 7, but in XP a have to turn if off in services to let the people connect to my server( i think this is the general problem, it just not letting other users to connect to mangosd from outside).

2. Someone else, except your brother tried to connect to your server from outside?

3. It not seems to be matter, but Skype ( if you don't turn it off of in preferences ) takes port 80 & 443.

4. What router do you have & have it the latest firmware update? Many issues becomes from there.

1. I'm not sure what brandmauer you're referring to. Is that a MaNGOS thing, or Windows?

2. I've tried connecting using my laptop from various other locations and I've been unsuccessful as well.

3. Skype is not installed on this machine. It's a fresh install of Windows with only the necessary programs needed to compile and configure MaNGOS installed on it.

4. I have a Netgear router with the latest firmware, but I've been using this router for quite some time and I haven't had any issues with people connecting previously.

Just one additional note: I work in IT for a living so feel free to be technical with your replies. They should be understood just fine.

Link to comment
Share on other sites

I will not read this entire conversation, but i will give you a short explanation of what you need to do:

Set realmlist entry (in realmlist table in database realmd) to your public ip address.

open required ports in case they are closed (if you have a router you most certainly most do port forwarding. On netgear routers i think you can set DMZ to skip port forwarding)

Then you must allow mangosd and realmd in your firewall as well. If you have a firewall

Link to comment
Share on other sites

I will not read this entire conversation, but i will give you a short explanation of what you need to do:

Set realmlist entry (in realmlist table in database realmd) to your public ip address.

open required ports in case they are closed (if you have a router you most certainly most do port forwarding. On netgear routers i think you can set DMZ to skip port forwarding)

Then you must allow mangosd and realmd in your firewall as well. If you have a firewall

All of these have been completed aside from allowing mangosd and realmd through the firewall, as this has been disabled completely.

Link to comment
Share on other sites

I will not read this entire conversation, but i will give you a short explanation of what you need to do:

Set realmlist entry (in realmlist table in database realmd) to your public ip address.

open required ports in case they are closed (if you have a router you most certainly most do port forwarding. On netgear routers i think you can set DMZ to skip port forwarding)

Then you must allow mangosd and realmd in your firewall as well. If you have a firewall

All of these have been completed aside from allowing mangosd and realmd through the firewall, as this has been disabled completely.

Are you really sure? Because if so, it would work to connect. Have you tested if others can connect? Because some routers do not have NAT loopback, which makes you unable to connect from the computer who is running the server (or something, i only read about NAT loopback on another forum)

Link to comment
Share on other sites

I've completed disabled the Windows firewall, so that's not the problem.

Additionally, I was checking to make sure the ports on my router were open and accessible using http://www.canyouseeme.org and I found something interesting. First I noticed that the server needs to be running otherwise this utility returns that the ports are closed. Once the server is started up I checked ports 8085 and 8086 and both were successful, however 3724 was not. The message it gave me was that the connection timed out rather than a message about it being blocked.

Anyone have any idears?

Link to comment
Share on other sites

I apologize in advance for the double post but I felt this was relevant and worth an additional post to re-alert those who have been involved in the discussion so far.

I was messing around with the ports for realmd and mangosd in the config files. Out of curiosity I set realmd to 8085 and my two realms to 8086 and 8087 (also adjusted the realm port in the Realmlist table to match). Then I used the port checker to see if the ports were open and accessible, which they all 3 were. I then started up the WoW client from an external location (work machine) to attempt to connect, but it hangs at Connecting for a minute and then goes to a new error message. This time I get Unable to Connect rather than Login Server Down.

I'm wondering if the WoW client is giving that error because it's trying to connect to the server through port 3724, which isn't being used? Does anyone know if the WoW client will connect on ANY port for the loginserver? Or JUST 3724? I would expect that since the port can be changed in the config files that the client should be able to connect on any port, but I'm not sure.

Link to comment
Share on other sites

I just had a problem like this running my server in Ubuntu.

mangosd.conf

BindIP = "0.0.0.0"

realmd.conf

BindIP = "0.0.0.0"

In the DB->realmd->realmlist

U need to put the IP (In Cata, DNS is bugged =( )

So the problem is, if u try to connect to the server and the server is in the same LAN u need to put the local IP.

Link to comment
Share on other sites

I just had a problem like this running my server in Ubuntu.

mangosd.conf

BindIP = "0.0.0.0"

realmd.conf

BindIP = "0.0.0.0"

In the DB->realmd->realmlist

U need to put the IP (In Cata, DNS is bugged =( )

So the problem is, if u try to connect to the server and the server is in the same LAN u need to put the local IP.

I'm not 100% sure what you're talking about but here's what I understood from your post:

Currently my realmd and mangosd config files have the BindIP set to 0.0.0.0 because this is the default. Do you mean I need to change this to a different IP address? If so, what IP?

Also, my realmlist table in the database already has the IP address instead of the dyndns because I knew this problem existed already.

Link to comment
Share on other sites

if your BindIP configs are set to 0.0.0.0 you shouldn't have to change them as this will tell mangosd and realmd to listen on any available interface.

You said you were able to connect to the server when everything was set to local addresses, when it is set to external are external clients able to connect?

I'm not sure about others but I'm a little unclear on what exactly your issue is. Also if I understand your post from 2012-10-02 09:38:54 correctly it sounds like your trying to create two realms, i assume one for the external/public IP and one for the local/private IP, as far as i know this will not work because mangosd will only update one realm and the other will just remain offline

Link to comment
Share on other sites

if your BindIP configs are set to 0.0.0.0 you shouldn't have to change them as this will tell mangosd and realmd to listen on any available interface.

You said you were able to connect to the server when everything was set to local addresses, when it is set to external are external clients able to connect?

I'm not sure about others but I'm a little unclear on what exactly your issue is. Also if I understand your post from 2012-10-02 09:38:54 correctly it sounds like your trying to create two realms, i assume one for the external/public IP and one for the local/private IP, as far as i know this will not work because mangosd will only update one realm and the other will just remain offline

I actually was able to resolve this issue this morning but adjusting the config files to use a different port for realmd. I was unaware that you needed to add the port when modifying realmlist.wtf. I'm able to connect to the login server now and access both realms.

Just to clear up any confusion you might have, I was having trouble connecting to the server from a location other than my own LAN. I have the server setup on a dedicated box in my house rather than my personal machine. Once I set the server up to be public (modifying config files, changing realmlist table, forwarding ports on the router) I was able to access the server from any other computer IN MY HOUSE, but not from a computer outside my house like my brother's computer at my parents' house for example. After changing the realmd port I'm able to connect now. Something with my router must be blocking port 3724.

As for the second realm, they're both external realm. One is blizzlike and one is going to be a custom realm. I wasn't trying to set up one internet and one external. They are both on my realmlist and accessible now that I've resolved the issue with the realmd port.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use