Jump to content
  • Problems with macros

    • Status: Not a bug
      Main Category: Core / Mangos Daemon
      Sub-Category: Code Enhancement
      Version: 0.20(currentmasterbranch) Milestone: 20 Priority: Low
      Implemented Version: 0.20

    Problems with macros

    A lot of scripts? commands? that worked in vanilla do not here, which ok, i assume is natural since there's guesswork entailed.
    Some of the ones that do not work, been a few hours since i gave up, lol, so forgot a lot :)

    /castsequence reset=[value]
    /use 13 or /use 14
    ability to combine trniket and/or inventory item with spell casting. I mean proper casting, shoot an Fball after proccing a trinket, drinking a pot

    User Feedback

    Recommended Comments

    I did not use complex macros in 1.12 and really did not get into them until 3.x so I cannot offer guidance here. My most complex macro was prior to 1.12.
    Before 1.10 or 1.11 that macro caused your player to jump up and then display the logout dialog, causing your player to stand in the air where he jumped. Cancel the logout dialog and repeat. You could get to ALL KINDS of places with that.


    Wait, macros are client-side. The server should not affect your macros. Perhaps the complex macros you are trying to use won't work in vanilla?

    Link to comment
    Share on other sites

    will try again :)

    i am not after guidance, i know what to do. I am posting in the bug section because commands accepted by the server in retail vanilla are ---[I]not[/I]--- recognised here. I do not know how you consider client side, but i do know what worked, or should have. Am in the bug section knowingly.
    the ones i listed are a good start, there are others i will be coming back to ammend the original OP with in due time.

    Link to comment
    Share on other sites

    What I am saying is that macros are not sent to the server. They're processed in your game client. The server only processes the commands your client sends based on your macros. Also, castsequence did not exist in vanilla WoW. If you google for castsequence and "wow vanilla" you will see several posts by players on Feenix and other Zero servers with the same issue because, as they state, it did not exist in vanilla. The client does not understand it so it cannot process it. A few links are below for reference.

    Proof it was added in 2.0.1:

    Others working very hard to try to make one for vanilla:

    More proof it does not work in 1.12:

    This is not a bug, this is your client not having the macro "castsequence" in it. To get that macro to work you must be running 2.0.1 or newer. Closing as "not a bug".

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use