Jump to content
  • Cannot aggro

    • Status: Cannot Reproduce
      Main Category: Core / Mangos Daemon
      Sub-Category: Combat
      Version: 21.14 Milestone: Unset Priority: New
      Implemented Version: Unset


    On westfall I cannot aggro some mobs.

    Starting to fight, my first hit is decreased from their hit point. But then the mob reset the aggro.

    And just after retry to aggro me, and immediatly reset.

    Note that their "familiar" can be fight normally. Example the murloc hunter cannot be fight but its crab familiar can be killed.

    Moving my character back to any other zone, permit it to fight normally.

    on the mangosd log, I see "creature started to attack player xxx" then "creature stopped to attack player xxx"


    This bug happen since february, and I have update to the latest github sources and still happen

    User Feedback

    Recommended Comments

    No GM is not enabled, I dont have touch anything GM related.

    But when seeking this issue, I found lot of people saying that, so I have tried to verify that GM didnt be enabled by a bug/anyting else.

    And it seems not enabled (according to mangos> gm ingame)


    - do you have a prodecure to verify I am not GM

    - does GM could be enabled only for a specfific "zone" (if not my problem is not begin GM)

    Link to comment
    Share on other sites

    I just tested this again, and I am unable to reproduce this issue with murlocs. 

    If your account level allows, try and use .npc info
    Please provide an entry for one of the NPCs causing an issue.

    To make sure gm is not on, log into your character and type .gm off
    No GM should not turn on/off over different zones.

    Link to comment
    Share on other sites

    does something is needed to run thoses commands ? because my character just said what I type. I have tried adding / or replacing . by / unsuccessfully.

    Note that murloc are not the only monsters affected, goretusk, defias... all monsters on the southwest.


    Additionnaly on the output of mangosd I have:

    creature 90292 stopped attacking player 149
    player 149 stopped attacking creature 90292
    creature 90292 stopped attacking player 149
    creature 90292 stopped attacking player 149
    creature 90292 stopped attacking player 149


    Link to comment
    Share on other sites

    Sounds like your account does not allow that command.   If I understand, this is your server? Is it local (game and server are run on the same machine) or is it connected remotly (game and server are on two different machines.)? What OS are you using?

    I have checked this over a few times now and am unable to reproduce this. I know you have said that you are using the current version of Mangos, but if you could please try this once again.. with a fresh clone of the server : mangostwo server 

    Link to comment
    Share on other sites

    This is now closed for further comments

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use