Jump to content
  • 0

Other users cannot connect to server on LAN



The client on the server can login and play fine.  However all other users on LAN can authenticate but gets stuck on realm selection screen and cannot enter.  I've turned off all firewalls and ports forward to the server.  


On the server side I get the following ACE error:

ACE_INET_Addr::ACE_INET_Addr: 555.555.555.555: Authoritive: Host not found

Edited by Kal
Additional info
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

i'm stuck at this point as well. did you ever figure this out?

**edit** i figured this out thanks Olion

download & install its https://dev.mysql.com/downloads/workbench/

open mysql workbench
-setup new connection
-changed connection method to "standard TC/IP over SSH"
-change SSH hostname to your server
-change usernames to the correct ones

test connection

open connection and enter your  passwords. ssh password first then MYSQL

open realm database
-open tables
- go down to realmlist and right click

click "select rows limit to 1000"

change address and local address to your servers ip 192.160.***.***

click apply

next... next... should get a confirmation that it changed successfully

should be good to connect from your lan or port forward to your server.



Edited by redalert11
  • Like 1
Link to comment
Share on other sites

  • 0

Check your content of the `realmlist` table in the `realmd` DB. The `realmlist`.`address` string field is used to tell the non-local clients on what host to look for the mangosd server (aka realm server). It might be either a full DNS hostname resolvable at your friends computers, or an IP (specifically, IPv4?) address accessible to them. It looks like your table contains the string 555.555.555.555 here, which is not satisfactory.

Link to comment
Share on other sites

  • 0

Thanks for the help, So I'm an extreme noobie on this I literally just downloaded and started to play with this two weeks ago.  When you say " 'realmd' DB" are you referring to the realmd.conf file? If so my settings are as follows

LoginDatabaseInfo      = ";3306;***;***;realmd"
LogsDir                = ""
PidFile                = ""

MaxPingTime            = 30
RealmServerPort        = 3724
BindIP                 = ""

LogLevel               = 0
LogTime                = 0
LogFile                = "world-realm.log"
LogTimestamp           = 0
LogFileLevel           = 0
LogColors              = "13 7 11 9"

UseProcessors          = 0
ProcessPriority        = 1
WaitAtStartupError     = 0
RealmsStateUpdateDelay = 20

WrongPass.MaxCount     = 3
WrongPass.BanTime      = 300
WrongPass.BanType      = 0

I get handshake and get all the way to realm selection but when I select the realm it does not enter.

Edited by Olion
SQL account should be a private information
Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use