Jump to content
  • 0

SOLVED: realmd in MangosTwo can't connect to the base though mangosd does


Ariador
 Share

Question

The realmd doesn't want to connect to database of MangosTwo, though mangosd does and starts properly. At MySQL workbench my user (mangos) also connects smoothly. Disabled SSL encryption at MySQL - didn't help. I think it's not an SSL issue, something wrong with realmd. My system is Ubuntu 20.04.4 LTS - updated freshly. Here's status text from terminal:

 

[email protected]:/etc/mysql/conf.d# systemctl status realmd
● realmd.service - Realmd service
     Loaded: loaded (/etc/systemd/system/realmd.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Thu 2022-05-26 05:58:19 EEST; 5s ago
    Process: 28236 ExecStart=/home/mangos/two/bin/realmd -c /home/mangos/two/etc/realmd.conf (code=exited, status=1/FAILURE)
   Main PID: 28236 (code=exited, status=1/FAILURE)

May 26 05:58:19 ASUS realmd[28236]: 2116012 [realm-daemon]
May 26 05:58:19 ASUS realmd[28236]: <Ctrl-C> to stop.
May 26 05:58:19 ASUS realmd[28236]:
May 26 05:58:19 ASUS realmd[28236]: Using configuration file /home/mangos/two/etc/realmd.conf.
May 26 05:58:19 ASUS realmd[28236]: Login Database total connections: 2
May 26 05:58:19 ASUS realmd[28236]: Could not connect to MySQL database at 127.0.0.1: SSL connection error: unknown error number
May 26 05:58:19 ASUS realmd[28236]:
May 26 05:58:19 ASUS realmd[28236]: Can not connect to database
May 26 05:58:19 ASUS systemd[1]: realmd.service: Main process exited, code=exited, status=1/FAILURE
May 26 05:58:19 ASUS systemd[1]: realmd.service: Failed with result 'exit-code'.

 

Any ideas?

EDIT: Got it. Just put 192.168.0.101 (or whatever you have as your local IP)  instead 127.0.0.1 in realmd.conf parameters and realmd started easily by the terminal command "systemctl start realmd". Perhaps WiFi connection must be on. Or just put "localhost" instead of 127.0.0.1 - it works. Don't forget to edit also mangosd.conf in mangos/etc and configurations files of your client (realmlist.wtf in /Data and config.wtf in /WTF). And use MySQL Workbench to put correct IP to the realmlist table.

Edited by Ariador
SOLVED
Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use