Jump to content
  • 0

mangos>Segmentation fault (core dumped)




After compiling mangos two with different compiler I get the same error when using libcrypto.so.3 which is throwing me this error:

kernel: [ 1926.500759] mangosd[20040]: segfault at 78 ip 00007f6c04483ec8 sp 00007f6bf19789f0 error 4 in libcrypto.so.3[7f6c043a3000+25e000]

realmd works fine
mangosd starts, I can remote and pass commands see screenshot below.

This error occurs when I try to connect to the realm.

Ubuntu server 22.04.2 LTS (8cpu / 8Go ram)
kernel: Linux mangosvm 5.15.0-60-generic #66-Ubuntu 
Mangostwo sources: https://github.com/mangostwo/server 

Compiled 3 times with each of the following:

gcc-11.3 (error with vmap/TileAssembler.cpp:390:10: internal compiler error: in compute_live_loop_exits, at tree-ssa-loop-manip.c:247)
gcc-10: worked
clang-15: worked, mangosd and realmd are running with this version of the compiler

:/opt/wotlk/bin$ ldd mangosd
        linux-vdso.so.1 (0x00007ffd50ae8000)
        libssl.so.3 => /lib/x86_64-linux-gnu/libssl.so.3 (0x00007f14302fa000)
        libcrypto.so.3 => /lib/x86_64-linux-gnu/libcrypto.so.3 (0x00007f142feb7000)
        libmysqlclient.so.21 => /lib/x86_64-linux-gnu/libmysqlclient.so.21 (0x00007f142f82e000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f142f812000)
        libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f142f5e8000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f142f501000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f142f4df000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f142f2b7000)
        libzstd.so.1 => /lib/x86_64-linux-gnu/libzstd.so.1 (0x00007f142f1e8000)
        libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f142f1d4000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f143104e000)


I tried with different options in CmakeLists.txt, but nothing works I even tried different libcrypto... same
Same error on my physical server as well where all db are running.

Any idea?



Edited by Yogsoggoth
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

@Yogsoggoth You'll need to install OpenSSL 1.1.x, not OpenSSL 3.x. Ubuntu 22.04 ships with OpenSSL 3.x by default.
Follow this below and you'll be up and running in no time.

To remove OpenSSL 3.x

sudo apt remove openssl libssl-dev

Install OpenSSL 1.1.x

# download binary openssl packages from Impish builds
wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/openssl_1.1.1f-1ubuntu2.19_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl-dev_1.1.1f-1ubuntu2.19_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1f-1ubuntu2.19_amd64.deb

# install downloaded binary packages
sudo dpkg -i libssl1.1_1.1.1f-1ubuntu2.19_amd64.deb
sudo dpkg -i openssl_1.1.1f-1ubuntu2.19_amd64.deb
sudo dpkg -i libssl-dev_1.1.1f-1ubuntu2.19_amd64.deb
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use