Jump to content

compiling error


Guest manofwar95
 Share

Recommended Posts

After running cmake in, /build. Then running make command. I get this error. Please help thanks.

$: make

Scanning dependencies of target genrev

[ 0%] Building CXX object CMakeFiles/genrev.dir/src/tools/genrevision/genrevision.cpp.o

Linking CXX executable genrev

[ 0%] Built target genrev

Scanning dependencies of target revision.h

[ 0%] Built target revision.h

Scanning dependencies of target TBB_Project

[ 0%] Creating directories for 'TBB_Project'

[ 0%] No download step for 'TBB_Project'

[ 0%] No patch step for 'TBB_Project'

[ 0%] No update step for 'TBB_Project'

[ 0%] No configure step for 'TBB_Project'

[ 0%] Performing build step for 'TBB_Project'

: command not founde_tbbvars.sh: line 28:

: command not founde_tbbvars.sh: line 28:

: command not founde_tbbvars.sh: line 28:

: command not founde_tbbvars.sh: line 28:

[ 0%] Performing install step for 'TBB_Project'

[ 0%] Completed 'TBB_Project'

[ 2%] Built target TBB_Project

Scanning dependencies of target ACE_Project

[ 2%] Creating directories for 'ACE_Project'

[ 2%] No download step for 'ACE_Project'

[ 2%] No patch step for 'ACE_Project'

[ 2%] No update step for 'ACE_Project'

[ 2%] Performing configure step for 'ACE_Project'

/bin/sh: /sources/zero/dep/ACE_wrappers/configure: Permission denied

make[2]: *** [dep/ACE_wrappers/ACE_Project-prefix/src/ACE_Project-stamp/ACE_Project-configure] Error 126

make[1]: *** [dep/ACE_wrappers/CMakeFiles/ACE_Project.dir/all] Error 2

make: *** [all] Error 2

Link to comment
Share on other sites

Permission denied

Guess you checked out as root. Chown and chmod should help. First got to mangosfolder and "# chown -r username *" and afterwards exit su and you should be able to build as user. Another not recommended option would be to compile as root user.

Regards

Skirnir

Link to comment
Share on other sites

Permission denied

Guess you checked out as root. Chown and chmod should help. First got to mangosfolder and "# chown -r username *" and afterwards exit su and you should be able to build as user. Another not recommended option would be to compile as root user.

Regards

Skirnir

I was building it as the root user, and that still doesn't explain the tbbvars.sh errors.

Link to comment
Share on other sites

$: make

Well using the $ as sign for root is rather unique, most commonly used is the #. Doubt that there is a distribution shipping a command $ for root. The tbbvars says that there is a command in line 28 that does not exist. I don't build zero have a look at the file and see whats the source of the problem. Maybe you have to install another package or need an updated version.

Regards

Skirnir

Link to comment
Share on other sites

$: make

Well using the $ as sign for root is rather unique, most commonly used is the #. Doubt that there is a distribution shipping a command $ for root. The tbbvars says that there is a command in line 28 that does not exist. I don't build zero have a look at the file and see whats the source of the problem. Maybe you have to install another package or need an updated version.

Regards

Skirnir

The symbol "$" is unique because I built my own GNU/Linux operating system, but it is based off of Ubuntu, and still runs everything ubuntu (server edition) does. I also tried on Gentoo and it didn't work.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use