Jump to content

PRJ0019 Error when Compiling


Recommended Posts

Hello,

I am using Visual C++ 2008 and every time I try to compile I get the following error message.

1 >------ Build started: Project: tbb, Configuration: Debug Win32 ------

1> Assembling ...

1> The command "ml.exe" is either misspelled or

1> could not be found.

1> Project: error PRJ0019: A tool returned an error code from the following source: "Assembling ..."

1> Build log was saved at "file: / / c: \\ mangos-mangos-ab8383d \\ win \\ VC90 \\ tbb__Win32_Release \\ BuildLog.htm".

1> tbb - 1 errors, 0 warning (s)

2 >------ Build started: Project: tbbmalloc, Configuration: Debug Win32 ------

2> Assembling ...

2> The command "ml.exe" is either misspelled or

2> could not be found.

2> Project: error PRJ0019: A tool returned an error code from the following source: "Assembling ..."

2> Build log was saved at "file: / / c: \\ mangos-mangos-ab8383d \\ win \\ VC90 \\ tbbmalloc__Win32_Release \\ BuildLog.htm".

2> tbbmalloc - 1 errors, 0 warning (s)

what may be the reason for this???

Thanks for your help.

Link to comment
Share on other sites

Depending on os ml.exe might just have wrong permissions

I am always forget any other OS, assuming that everyone is using Windows :)

Windows != Windows There are serveral different windows versions, i know some people have had problems with win7 permissions (including myself) Tell us what OS you use.

Link to comment
Share on other sites

http://msdn.microsoft.com/en-us/library/yzk29wdw%28v=VS.90%29.aspx

"This error can also occur when you are running as a member of the Users group and Administrative access is needed. For more information, see Running as a Member of the Users Group."

So lillecarl most likely right.

Windows != Windows There are serveral different windows versions, i know some people have had problems with win7 permissions (including myself) Tell us what OS you use.

Im using XP. Sorry :)

Link to comment
Share on other sites

I use Windows Web Server 2008 R2 x64

Microsoft Visual Studio 2008

Version 9.0.30729.1 SP

Microsoft .NET Framework

Version 3.5 SP1

installed edition: VC Express

Microsoft Visual C++ 2008 91909-152-0000052-60746

Microsoft Visual C++ 2008

2008 r2 is a "fork" from win7 i think both have the minwin kernel and the same base code, wich means its more likley to be a permission error, what kind of user are you running under? Try a admin user or reinstall VS.

- LilleCarl

Link to comment
Share on other sites

I am logged in as admin but it does not help. VS reinstall did not help too.

I have no idea what this is about. where can I get this ml.exe from?

Should be installed in C:\\Program Files (x86)\\Microsoft Visual Studio 10.0\\VC\\bin

9.0* Anyways you might have to take ownership of the file.

Oh thought he was using 2010. Yeah, should be 9.0, not 10.0.

Link to comment
Share on other sites

is anyone of you able to compile the newest core for me and make it available for download?`

I think that would be the best way xD

Thanks a lot

Teach a man to fish, blah blah blah.

Point is, if that person were to get eaten by ravenous hamsters, how would you update your server? Or would you just use ancient mangos?

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use