Jump to content
  • 0

vmaps for 434



Hi All,

This is the first time I have ever tried mangos, so far so good, I have compiled the core, installed the db.


I am attempting to extract vmaps (maps and dbc's are done) and after running for ages (I know it takes a while) it was spamming these...

#Can't open World\\Maps\\Kalimdor\\Kalimdor_40_0_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_1_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_2_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_3_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_4_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_5_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_6_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_7_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_8_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_9_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_10_obj0.adt, err=2!

Can't open World\\Maps\\Kalimdor\\Kalimdor_40_11_obj0.adt, err=2!

Now it is complete I have a buildings folder but no vmaps.


I have disabled them in the configs so I can move on which brings me to

Issue 2:

When I run mangos.exe it crashes and the last thing on the server log is :

ERROR:Incorrect DataDir value in mangosd.conf or not found build info (outdated DBC files). Required one from builds: 15595 Please extract correct DBC files.

dbc's were just extracted :(

I know there are alot of topics already on these issues but I can't find one specific to my issue.

I can't seem to find a windows tutorial either? Anyone know of good one?

Please and thanks - looking forward to giving mangos a try :)


Got working dbc's using trinity's extractor ;)

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

I managed to get it working and I have a log file which says:

Thu Oct 4 23:32:52 AUSEST 2012: Start extracting dataz for MaNGOS

DBC and map files will be extracted

Vmaps will be extracted

Mmaps will be extracted with 4 processes

Thu Oct 4 23:32:52 AUSEST 2012: Start extraction of DBCs and map files...

Thu Oct 4 23:37:31 AUSEST 2012: Extracting of DBCs and map files finished

Thu Oct 4 23:37:31 AUSEST 2012: Start extraction of vmaps...

Fri Oct 5 00:52:04 AUSEST 2012: Extracting of vmaps finished

Fri Oct 5 00:52:05 AUSEST 2012: Start assembling of vmaps...

Fri Oct 5 00:52:46 AUSEST 2012: Assembling of vmaps finished

Now when I load the world with vmaps enabled it says :

2012-10-05 10:05:07 ERROR:VMap file 'D:\\REALMS\\434_data/vmaps/001.vmtree' is missing or point to wrong version vmap file, redo vmaps with latest vmap_assembler.exe program

2012-10-05 10:05:07 ERROR:Correct *.map files not found in path 'D:\\REALMS\\434_data/maps' or *.vmtree/*.vmtile files in 'D:\\REALMS\\434_data/vmaps'. Please place *.map and vmap files in appropriate directories or correct the DataDir value in the mangosd.conf file.

My DataDir contains the newly created mmap, map, buildings, dbc, and vmaps so not sure why there would be one missing?

Also, would this all have anything to do with my char walking around like a thunderbird with her arms in the air?? :P

Any help appreciated please and thanks :)

Link to comment
Share on other sites

vmap assembler just closes as soon as I open it, too fast to even see what it says.

ExtractResources.sh (or whatever it is called has in the logs that it assembled them as I said above

Fri Oct 5 00:52:05 AUSEST 2012: Start assembling of vmaps...

Fri Oct 5 00:52:46 AUSEST 2012: Assembling of vmaps finished

Link to comment
Share on other sites

when running the extractor, the files created by ad.exe need to still be inplace as vmap assembler uses them - i would advise letting the files get created in their default place since some of the tools are not that clever when folder names are changed

that may be why your vmaps finished so quickly and produced nothing

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use