Jump to content
  • 0

mangoszero database update error, indicated update is older


kiwi girl

Question

Hi all,

I've just tried to update my personal mangoszero suite as the last time I updated was last year. I have recompiled from scratch, although I brought over vmaps and dbc from my earlier build because I couldn't follow the instructions on how to create them using the latest version of the files on github.

Because I already have characters populated in the MySQL database, I updated the files using sql/updates instead of reinstalling the database. This was so that my characters weren't deleted. I think I installed from z1765, and definitely went through to z1842-xxxxx-01 and everything updated without a hitch.

My realmd is running fine, but my mangosd is returning an error. The error is:

SQL: SELECT required_z1756_s1308_01_mangos_instance_template FROM db_version LIMIT 1

query ERROR: Unknown column 'required_z1756_s1308_01_mangos_instance_template' in 'field list'

[0 ms] SQL: SELECT * FROM db_version LIMIT 1

The table 'db_version' in your [WORLD] database indicates that this database is out of date!

(A) You have: --> 'z1842_xxxxx_01_mangos_spell_template.sql'

(B) You need: --> 'z1756_s1308_01_mangos_instance_template'

You must apply all updates after (A) to (B) to use mangos with this database. These updates are included in the sql/updates folder.

The problem seems to be that it's expecting an older update than I have, so I'm not sure how to fix this error. Running the suggested z1756 sql code is giving me an error, as that code will be seeing the wrong update information.

I don't know where this is being called from to fix the issue. If someone could advise what I have done wrong, and how to fix this, I would appreciate the help.

I've used parentheses instead of square brackets as I was getting a html error when trying to post.

Link to comment
Share on other sites

22 answers to this question

Recommended Posts

I had this issue as well.

Even applying the sql updates to the database from the latest core does not help.

To get around it I just "drop" the "db version" from my database then edit one to match what its looking for and apply to my database.

then the world server starts with no issues.

There is a problem between the darabase and core though thats for sure and it needs to be looked into.

Link to comment
Share on other sites

To get around it I just "drop" the "db version" from my database then edit one to match what its looking for and apply to my database.

Do I just need to edit the column name in the db_version table in the mangos set of tables?

I was wondering if the xxxxx in the name meant something, like it wasn't promulgated through with the rest of the code. I was also wondering what called that table, to see if I could edit the call to the correct update name.

But yeah, spent around 5 hours to get to this point and now can't run the server. :(

Link to comment
Share on other sites

I wonder: what branch of mangos-zero server did you build? Master, develop, another ? Currently, only the develop branch is compatible with last database version.

The "xxxxx" from the db_version table has no meaning for mangos-zero. You don't have to worry about this.

Link to comment
Share on other sites

I wonder: what branch of mangos-zero server did you build? Master, develop, another ?

I did the git clone call to: https://github.com/mangos-zero/database for the database (but did the updates manually to the database in Navicat) and to: https://github.com/mangos-zero/server for the server. I read the note about the master and develop aspects, but didn't understand how this affected the path call. Now I have gone back and I see the branch dropdown option, and it's set to develop, which appears to be the default. So it should be working? Or should I have chosen master for everything? WoW loaded before I updated the mangos set of tables in the database, as I tested at that point as I had taken a copy of everything but the database.

The "xxxxx" from the db_version table has no meaning for mangos-zero. You don't have to worry about this.

Ah, thanks for pointing that out. I do read the readme notes, but wasn't sure if the "xxxxx" had any special meaning.

Link to comment
Share on other sites

To be sure I understand what you have done:

- you have update your mangos-zero database with the various updates in the update folder

- you have downloaded and build mangos-zero server (develop branch)

Is that correct?

If so, could you check that the file /src/shared/revision_sql.h has the following content:

#ifndef __REVISION_SQL_H__
#define __REVISION_SQL_H__
#define REVISION_DB_CHARACTERS "required_z1597_s1099_02_characters_pet_aura"
#define REVISION_DB_MANGOS "required_z1842_xxxxx_01_mangos_spell_template"
#define REVISION_DB_REALMD "required_10008_01_realmd_realmd_db_version"
#endif // __REVISION_SQL_H__

Link to comment
Share on other sites

#ifndef __REVISION_SQL_H__
#define __REVISION_SQL_H__
#define REVISION_DB_CHARACTERS "required_z1597_s1099_02_characters_pet_aura"
#define REVISION_DB_MANGOS "required_z1842_xxxxx_01_mangos_spell_template"
#define REVISION_DB_REALMD "required_10008_01_realmd_realmd_db_version"
#endif // __REVISION_SQL_H__

Hi Cala, yes that is the content in my revision_sql.h file.

Link to comment
Share on other sites

Hi Cala,

Thanks for your patience and help. It worked fine with the core recompile etc until I updated the tables in the db, which were all mangos (database? not sure what the object is inside the db above the tables) updates.

I have a clone of the db on another drive. I could copy over the db I have now, and then see if it works. I could then do one SQL update at a time and see which one breaks the install. Would that help?

Link to comment
Share on other sites

Yes, last core compiled fine. I'm running Windows 7 Ultimate but can only compile with 32-bit. Which is what I did last year and it worked fine.

The updates from sql/updates each ran without error.

realmd runs fine but mangosd returns the error that I posted at the start of the thread. It returns it as the first comment, so I assume it checks the database integrity as one of its initial tasks.

Link to comment
Share on other sites

Yes, last core compiled fine. I'm running Windows 7 Ultimate but can only compile with 32-bit. Which is what I did last year and it worked fine.

The updates from sql/updates each ran without error.

realmd runs fine but mangosd returns the error that I posted at the start of the thread. It returns it as the first comment, so I assume it checks the database integrity as one of its initial tasks.

For 64 Bit you need Windows 7 SDK

The other Problem you 100% sure you have the last core from here https://github.com/mangos-zero/server and not a other branch ?

Link to comment
Share on other sites

Maybe a stupid question but are you sure that:

- you do not have multiple mangos databases and/or config files ?

- you do not have multiple mangos daemon and/or config files ?

Because your error message clearly states that your database is up to date. It also says that your mangos core is out of date. Maybe you've compiled a new one but tried to launch an old one?

Link to comment
Share on other sites

The steps I followed were:

  • copy the previous WoW files (excluding the db files, which are saved under an xampp path off the root directory) and rename the files by putting "old" at the end of the root path folder.
  • download the /server /database and /scriptdev0
  • compile the new version using mangosdVC100 using Visual C++ Express 2010, compiled without error.
  • I used the updated Buildings from the latest compile, but /dbc /maps and /vmaps from earlier compile.
  • I used my previous mangosd.exe and realmd.exe but used the latest version of the other files. The only reason I didn't replace the two .exe files is that I have changed some of the values in the files.
  • I then manually updated the MySQL database using Navicat lite, by running the SQL update files through the Navicat interface. All the updates related to the mangos (not sure of object name, contains all the mangos_ tables). Prior to doing this, WoW started fine. Then once I updated the SQL tables, I got that error.

So yes, I have multiple config files, but they're in different directory structures and the shortcuts on the desktop I use to run the realmd and mangosd exe files are pointing at the correct (i.e. updated) directory.

I made sure I clicked through https://github.com/mangos-zero to get the downloads, and I copied and pasted the url into TortoiseGit. I'll roll back the database and see if it works tomorrow. The only reason I was updating was due to odd pet behaviour (pets not swimming, but walking on the bottom of water areas) and the old npcs and pets passing through layers - Raven's Hill cemetary being one example. I was hoping the updated core etc would fix this behaviour.

Thanks again to everyone for their help.

Link to comment
Share on other sites

  • I used my previous mangosd.exe and realmd.exe but used the latest version of the other files. The only reason I didn't replace the two .exe files is that I have changed some of the values in the files.

I think we've found the problem: mangosd.exe looks for the DB version table. If you use an older .exe it will look for an older DB version while your database is up to date. When building, a new mangosd.exe was created. You should use this one instead.

Link to comment
Share on other sites

Thanks all, it was the config files I wanted to retain with the values, not the executables.

I have now copied all the Win32 release contents into the server folder as per normal. The issue is fixed, but I have a new problem.

A message box called "mangosd.exe - Entry Point Not Found' has occurred.

The error is:

I can start the server, and logged in with a character. I have no clothes, and nothing in my character's bags. There are no NPCs. My character has no quests, but I have my spells, and my talents are fine too. However, my characters all show the correct levels, and the one I had logged in with has the correct amount of gold.

I have compared the two mangosd.conf files in Notepad++ and made the one change from the newer conf, which appeared to be associated with a maps line. I am still getting that message box.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use