Jump to content
  • 0

[Three] Compiling vmapextractor on linux




I have a question about the vmapextractor in mangos three.

When I try to compile the vmapextractor contained in mangos three (it worked in MaNGOS zero and one) on my linux host I get the error:

$ cmake .

-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Warning (dev) at vmapextract/CMakeLists.txt:14 (LINK_DIRECTORIES):
 This command specifies the relative path


 as a link directory.

 Policy CMP0015 is not set: link_directories() treats paths relative to the
 source dir.  Run "cmake --help-policy CMP0015" for policy details.  Use the
 cmake_policy command to set the policy and suppress this warning.
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring done
CMake Error in vmapextract/CMakeLists.txt:
 Cannot find source file "mpq_libmpq.cpp".  Tried extensions .c .C .c++ .cc
 .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp .hxx .in .txx

libmpq is not part of the repository of mangosthree, is it only using stormlib?

Because the CMakeLists.txt files still have the libmpq directory in it:


And if I download the needed libmpq files from the mangoszero respo I get compiling errors.

What do I have to do to get the vmapextractor compiled?


Link to comment
Share on other sites

2 answers to this question

Recommended Posts


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use