Jump to content
  • 0

endoralol

Question

9 answers to this question

Recommended Posts

Looks like CMake having no "write" permission on the C:\MangosSource\ folder. It could be UAC windows mechanics, or an antivirus blocking "suspicious" writes to C: drive.

Okej i added in UAC lowest security is possible, and turned off antivirus + opened cmake with administrator. Didn't help me

Link to post
Share on other sites

My apologies, probably I was wrong about the cause. Cited from here:

anyone using CMake 2.8.1 (latest as of May 21, 2010) and Visual Studio 2010 Express will need to update the CMakeVS10FindMake.cmake file inside of the CMake\Modules folder.

Updating CMake (I have 3.4.3, EasyBuild sets up 3.5.0, both are ok) should solve the issue. The Visual Studio also looks too old, but it is marked as acceptable one.

Link to post
Share on other sites
My apologies, probably I was wrong about the cause. Cited from here:

Updating CMake (I have 3.4.3, EasyBuild sets up 3.5.0, both are ok) should solve the issue. The Visual Studio also looks too old, but it is marked as acceptable one.

Have Cmake 3.5.2 now, Visual Studio 2015 still no help

Error log from vs 2015

The C compiler identification is unknown

The CXX compiler identification is unknown

CMake Error at CMakeLists.txt:27 (project):

No CMAKE_C_COMPILER could be found.

CMake Error at CMakeLists.txt:27 (project):

No CMAKE_CXX_COMPILER could be found.

Configuring incomplete, errors occurred!

See also "C:/Users/Denis/Desktop/Trinity 2.4.3/buils/CMakeFiles/CMakeOutput.log".

See also "C:/Users/Denis/Desktop/Trinity 2.4.3/buils/CMakeFiles/CMakeError.log".

error log from vs 2010

The C compiler identification is MSVC 16.0.30319.1

The CXX compiler identification is MSVC 16.0.30319.1

Check for working C compiler using: Visual Studio 10 2010

Check for working C compiler using: Visual Studio 10 2010 -- works

Detecting C compiler ABI info

Detecting C compiler ABI info - done

Check for working CXX compiler using: Visual Studio 10 2010

Check for working CXX compiler using: Visual Studio 10 2010 -- works

Detecting CXX compiler ABI info

Detecting CXX compiler ABI info - done

Detecting CXX compile features

Detecting CXX compile features - done

This script builds the MaNGOS server.

Options that can be used in order to configure the process:

General:

CMAKE_INSTALL_PREFIX Path where the server should be installed to

CONF_DIR Path to the configs, can be absolute or relative.

PCH Use precompiled headers

DEBUG Debug mode

USE_STD_MALLOC Use standard malloc instead of TBB

ACE_USE_EXTERNAL Use external ACE

BUILD_TOOLS Build map/vmap/mmap extractors

SOAP Enable remote access via SOAP

Scripting engines:

SCRIPT_LIB_ELUNA Compile with support for Eluna scripts

SCRIPT_LIB_SD2 Compile with support for ScriptDev2 scripts

To set an option simply type -D<OPTION>=<VALUE> after 'cmake <srcs>'.

Also, you can specify the generator with -G. see 'cmake --help' for more details

For example: cmake .. -DDEBUG=1 -DCMAKE_INSTALL_PREFIX=/opt/mangosNote:OnUNIXsystems,CONF_DIRisrelativetothebinfolder.

Detected 32-bit platform.

Found Git: C:/Program Files/Git/cmd/git.exe

MaNGOS-Core revision : d0a69c958e5564c18ad8c7d6d8f9f8e10d8b2d30

Install server to : C:/Users/Denis/Desktop/Trinity 2.4.3/buils/bin

Install configs to : C:/Users/Denis/Desktop/Trinity 2.4.3/buils/bin/

Search configs from : binary directory (default)

Support for SOAP : No (default)

Script engine Eluna : Yes (default)

Script engine SD2 : Yes (default)

Build tools : Yes (default)

Use PCH : Yes (default)

Build in debug-mode : No (default)

CMake Error at CMakeLists.txt:407 (add_subdirectory):

The source directory

C:/MangosSource/server/server/dep

does not contain a CMakeLists.txt file.

CMake Warning (dev) at CMakeLists.txt:452 (if):

Policy CMP0054 is not set: Only interpret if() arguments as variables or

keywords when unquoted. Run "cmake --help-policy CMP0054" for policy

details. Use the cmake_policy command to set the policy and suppress this

warning.

Quoted variables like "MSVC" will no longer be dereferenced when the policy

is set to NEW. Since the policy is not set the OLD behavior will be used.

This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at src/game/AuctionHouseBot/CMakeLists.txt:21 (add_custom_command):

Policy CMP0040 is not set: The target in the TARGET signature of

add_custom_command() must exist. Run "cmake --help-policy CMP0040" for

policy details. Use the cmake_policy command to set the policy and

suppress this warning.

TARGET 'game' was not created in this directory.

This warning is for project developers. Use -Wno-dev to suppress it.

CMake Error at src/CMakeLists.txt:51 (add_subdirectory):

The source directory

C:/MangosSource/server/server/src/realmd

does not contain a CMakeLists.txt file.

CMake Error at src/modules/CMakeLists.txt:10 (add_subdirectory):

The source directory

C:/MangosSource/server/server/src/modules/Eluna

does not contain a CMakeLists.txt file.

Configuring incomplete, errors occurred!

See also "C:/Users/Denis/Desktop/Trinity 2.4.3/buils/CMakeFiles/CMakeOutput.log".

Link to post
Share on other sites

17>C:\Users\Denis\Desktop\server-release20\src\game\WorldHandlers\World.cpp(1979): error C3688: invalid literal suffix 'UI64FMTD'; literal operator or literal operator template 'operator ""UI64FMTD' not found

17>C:\Users\Denis\Desktop\server-release20\src\game\WorldHandlers\World.cpp(1990): error C3688: invalid literal suffix 'UI64FMTD'; literal operator or literal operator template 'operator ""UI64FMTD' not found

18>------ Build started: Project: mangosd, Configuration: Release Win32 ------

18> Building Custom Rule C:/Users/Denis/Desktop/server-release20/src/mangosd/CMakeLists.txt

18> CMake does not need to re-run because C:\Users\Denis\Desktop\MangosSource\build\src\mangosd\CMakeFiles\generate.stamp is up-to-date.

18> CliRunnable.cpp

18> Main.cpp

18> Master.cpp

18> RASocket.cpp

18> WorldRunnable.cpp

18>LINK : fatal error LNK1181: cannot open input file '..\game\Release\game.lib'

19>------ Build started: Project: ALL_BUILD, Configuration: Release Win32 ------

19> Building Custom Rule C:/Users/Denis/Desktop/server-release20/CMakeLists.txt

19> CMake does not need to re-run because C:\Users\Denis\Desktop\MangosSource\build\CMakeFiles\generate.stamp is up-to-date.

20>------ Skipped Build: Project: INSTALL, Configuration: Release Win32 ------

20>Project not selected to build for this solution configuration

========== Build: 16 succeeded, 2 failed, 0 up-to-date, 2 skipped ==========

We made cmake proggress, we failed on compile, new issue is 17>C:\Users\Denis\Desktop\server-release20\src\game\WorldHandlers\World.cpp(1979): error C3688: invalid literal suffix 'UI64FMTD'; literal operator or literal operator template 'operator ""UI64FMTD' not found

17>C:\Users\Denis\Desktop\server-release20\src\game\WorldHandlers\World.cpp(1990): error C3688: invalid literal suffix 'UI64FMTD'; literal operator or literal operator template 'operator ""UI64FMTD' not found

18>------ Build started: Project: mangosd, Configuration: Release Win32 ------

18> Building Custom Rule C:/Users/Denis/Desktop/server-release20/src/mangosd/CMakeLists.txt

18> CMake does not need to re-run because C:\Users\Denis\Desktop\MangosSource\build\src\mangosd\CMakeFiles\generate.stamp is up-to-date.

18> CliRunnable.cpp

18> Main.cpp

18> Master.cpp

18> RASocket.cpp

18> WorldRunnable.cpp

18>LINK : fatal error LNK1181: cannot open input file '..\game\Release\game.lib'

19>------ Build started: Project: ALL_BUILD, Configuration: Release Win32 ------

19> Building Custom Rule C:/Users/Denis/Desktop/server-release20/CMakeLists.txt

19> CMake does not need to re-run because C:\Users\Denis\Desktop\MangosSource\build\CMakeFiles\generate.stamp is up-to-date.

20>------ Skipped Build: Project: INSTALL, Configuration: Release Win32 ------

20>Project not selected to build for this solution configuration

========== Build: 16 succeeded, 2 failed, 0 up-to-date, 2 skipped ==========

Anyone know?

Link to post
Share on other sites

2016-05-07 19:21:35 SQL: SELECT required_20007_01_Rel20_Release_Prep FROM db_version LIMIT 1

2016-05-07 19:21:35 query ERROR: Unknown column 'required_20007_01_Rel20_Release_Prep' in 'field list'

2016-05-07 19:21:35 The table `db_version` in your [WORLD] database indicates that this database is out of date!

2016-05-07 19:21:35

2016-05-07 19:21:35 [A] You have: --> `20007_18_Deadmines_Mr_Smite_Corrections.sql`

2016-05-07 19:21:35

2016-05-07 19:21:35 You need: --> `20007_01_Rel20_Release_Prep.sql`

2016-05-07 19:21:35

2016-05-07 19:21:35 You must apply all updates after [A] to to use mangos with this database.

2016-05-07 19:21:35 These updates are included in the sql/updates folder.

2016-05-07 19:21:35 Please read the included [README] in sql/updates for instructions on updating.

We tried to update, but errors are comming.. it asks for older version hotfixes and other shits are added already. realmd.exe is started. only mangos suck dicks, anyone knows how to fix it?

Link to post
Share on other sites

You have a newer World database than the core expects, so no updates may help. Sorry I cannot help efficiently with Release20 version. I could suppose applying the following change to the World database as a dirty workaround:

ALTER TABLE `db_version` CHANGE COLUMN `20007_18_Deadmines_Mr_Smite_Corrections.sql` `20007_01_Rel20_Release_Prep.sql` BIT;

Due to the inconsistency, you will lose not so much (if ever) considering that Rel20 itself is too old and bad. But the core should start finally.

Most issues were due to git clone command: omitted "--recursive" parameter (fixed now) and "-b Develop21" to use current develop branch.

Link to post
Share on other sites
You have a newer World database than the core expects, so no updates may help. Sorry I cannot help efficiently with Release20 version. I could suppose applying the following change to the World database as a dirty workaround:

ALTER TABLE `db_version` CHANGE COLUMN `20007_18_Deadmines_Mr_Smite_Corrections.sql` `20007_01_Rel20_Release_Prep.sql` BIT;

Due to the inconsistency, you will lose not so much (if ever) considering that Rel20 itself is too old and bad. But the core should start finally.

Most issues were due to git clone command: omitted "--recursive" parameter (fixed now) and "-b Develop21" to use current develop branch.

ALTER TABLE `db_version` add COLUMN `20007_01_Rel20_Release_Prep.sql` BIT;

removed the old one, thats how i fixed issue

new issue is

WorldSocket::handle_input: Peer error closing connection errno = Invalid argument

WorldSocket::HandleAuthSession: client 5875, unk2 0, account ADMINISTRATOR, clientseed 384865757

WorldSocket::HandleAuthSession: (s,v) check s: 817EBB6FB5249F3BC41E13D8EB9A30CC30BA2CE465082A982BC68384429D492D v: 4574BE2A05400A9D4F55708E637E8EF62DBAAC38AE81B9F78B0CB28D19CF0EF8

WorldSocket::HandleAuthSession: Sent Auth Response (authentification failed).

WorldSocket::handle_input: Peer error closing connection errno = Invalid argument

first time opening wow, when u delete wtf folder where it keeps configuration of wow, first time launching wow, it actually logins in account fine, if you by some chance logout, and try to login again, it will keep disconnect, and everytime u delete wtf folder and go ingame it will be fixed, but same shit happends if u logout.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use