Jump to content
  • Quest NPCs do not follow their courses...

    • Status: Not a bug
      Main Category: Quests
      Sub-Category: Quest
      Version: 22.x (Current Master Branch) Milestone: 20 Priority: New
      Implemented Version: 0.20

    Quest NPCs do not follow their courses...

    Since the latest update I can not get ANY quest mob to move. I have tried numerous quests including two in Ashenvale (one where you accept the quest and the orc is supposed to attack a bunch of sentinels and one at Zoram'gar where you have to go to an island and kill a hydra) and upon accepting the quest the NPCs simply stand still. These quests worked before, and do not now. Not sure if this is DB, scripts, or server related, so I posted this here.

    User Feedback

    Recommended Comments

    Are you running R21 or R20? What build? With my build from last week all quests involving NPCs pathing has stopped working. It isn't mmaps because regular mobs and such work fine.


    I believe I figured it out, to an extent.
    DoScriptText with source Creature (Entry: 12717 Guid: 33115) could not find text entry -1000501.
    SD3: EscortAI Start with 0 waypoints (possible missing entry in script_waypoint).
    My database was created eons ago and has been updated to the latest version, but apparently the waypoints or something did not update, or something. I will look into it, but something is not right here.

    Link to comment
    Share on other sites

    One of the database updates wiped my waypoints out. I am not sure which one, but will begin looking through the updates I ran and try to make heads or tails of it. I restored them using the full DB script for that table and all is good again.

    Link to comment
    Share on other sites

    This is now closed for further comments

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use