Jump to content
  • Starting the MaNGOS Four server

    • Status: In Progress
      Main Category: Core / Mangos Daemon
      Sub-Category: Core Crash
      Version: 0.18 Milestone: 20 Priority: Low
      Implemented Version: 0.20

    This thread deals with the starting up of the MaNGOS Four server

    [SIZE=3][CENTER]---=== note to all [COLOR="#0000FF"]***[/COLOR] [COLOR="#FF0000"]NOT PLAYABLE/USABLE AT PRESENT[/COLOR] [COLOR="#0000FF"]***[/COLOR] still in very early development ===---[/CENTER][/SIZE]

    This thread has been created primarily for my own purposes, as I wish to put in some time on the creation/development of this server emulator :)

    Any constructive input by others will be greatly appreciated :D

    I'll alter/update this thread as I progress with this task/project.

    [COLOR="#0000FF"]Where are we with this?[/COLOR]

    Well, apparently Antz did get it to the point where he was able to bring up the character selection screen, so the server should be running at least.

    [COLOR="#0000FF"]Where am I with this?[/COLOR]

    Totally confuzzled, mind a void!

    Actually, the last time I tried to do anything, I could not even get the server to run. It refused to accept the game data files I extracted.

    Anyway, time to have another go at this!

    NOTE: This thread will only deal with the starting up of the server and everything leading up to that point. All other stages/issues will be dealt with in other threads.

    User Feedback

    Recommended Comments

    YEY, I just successfully got the server to run and not crash :D

    The thing is the installation was from my previous attempt, so not sure what happened to make it work now! :confused:

    What I'll do is install another one from scratch... and pray.


    Server failed to run after the fresh installation:
    [B][COLOR="#FF0000"]Correct *.map files not found in ../data/maps[/COLOR][/B]

    Checking the [B]component.wow-enUS.txt[/B] file in the dbc folder, it reports the client build to be 18273.

    MaNGOS Four needs 18414.

    I applied a means to trick it (thanks, Antz) by altering the code in the [B]system.cpp[/B] file but it still failed, coming up with the same error.

    code added at 3 points in the [B]system.cpp[/B]
    if (build == 18273)
    build = 18414;

    Although whilst extracting the data it said the build was 18414, it still showed as 18273 in the [B]component.wow-enUS.txt[/B] file.

    I'll have to revisit this at another time :(

    EDIT: Thinking about it, I don't know how that hack would make it work, unless the server is only looking for some sort of label/mark in the files that says what version the build is. If there are checks on the size of files, this would obviously fail!
    Hmm, I must have gotten the proper build from somewhere! Damn gremlins must've half inched it!!!

    Link to comment
    Share on other sites

    Nice that you succeed in that, but i have a question and don't get me wrong , should't we first try and get the servers ZERO, ONE and TWO to run without any flaws first then? i know thats allot of work an you all doing a great job at it, but for example im testing the server Two on covenant, and it has issues, now and then the core craches and other stuff, like quests and respawn times,

    Link to comment
    Share on other sites

    Thanks, gambit2312 :)

    Yes, it would make sense to concentrate on the other cores, but I think if I did that, this could easily end up being like a job

    Saying that though, my focus is primarily on Zero, and applying fixes to the other cores that I have achieved for Zero that are also relevant to them.

    MaNGOS Four is a nice challenge that I think I will enjoy wrestling with :) Plus plenty to learn from it.

    I don't know what happened to get the MaNGOS Four server to run earlier, but I just did a fresh install and the damn thing is complaining about the version of the game data (maps, vmaps, etc.) Which is the issue I had the last time I tried this. At some point last time I tried this, I obviously managed to extract the correct version of the files, but I can't find any mention of it in my notes!!!!
    Anyway, I'll write it down here this time!

    Of course, I now have to figure out how to get those correct data files again, :confused: lol and damn! :mad: :o :)

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use