Jump to content

[Bug] GO already in use

Guest Turok

Recommended Posts

Mangos Version: 9792

Custom Patches: None

SD2 Version: 1679

Database Name and Version : UDB Rev. 390

I had this bug already a long time but never really found out what is causing this.

If you try to loot a go (for collect quest) sometimes the loot doesn't open. If you try to loot again you only get the message "this is already in use".

Object I tried: http://www.wowhead.com/object=183394 but same applies on herbs

This only happens if the distance between you and the go is more than 5 yards.

Client shows go as lootable (cursor changes) already at about 5.7 yards. (using .distance command).

It seems like the problem is caused because in object.h INTERACTION_DISTANCE is set to 5.0 but client-side distance check is about 5.7(?). I changed to 5.7 in the code and the bug is fixed for me.

Can somebody confirm this? Sorry if this has already been reported I tried to search but couldn't find anything related.

Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use