Jump to content

[Mangos-Zero] No npc's/monsters (linux)


Recommended Posts

My server compiled correctly, I have my maps/vmaps/dbc folders setup, but importing the database into mysql seems to be the one part I can't get right. I think this is why I can never get any npc's or monsters in my world.

I have the mangos-zero database via "git clone git://github.com/mangos-zero/database", but unsure of what to do from there. Does anyone know what editing needs to be done to these files? Or any guide out there that works with the latest database?

Seems like changing the user:password in the mysql_info file, and then running mysql_import, should be all I need to do, but that didn't work at all. It seems like the sql's that come in the server/sql folder, and the sql's that come in the database use completely different settings. Is there no consolidation for these database files? It just seems to mess everything up when I import, because it's always telling my root user that access is denied for such-and-such database. Which is odd considering it is a ROOT user, and I did specify root under the mysql_info file.

I've learned a lot just getting to this point, but mysql is kicking my butt!

Link to comment
Share on other sites

I did read through the README that the database comes with. It just says to edit mysql_info, then run mysql_import, which is what I did. The installation procedures that come with the server and the database are vague, making it difficult to follow unless you already know exactly what to do. That's probably one of the reasons there are so many different guides floating around... because there is an evident need for them.

Link to comment
Share on other sites

I purged mysql-server from my system for a fresh start.

So then what is happening when I try to import create_mysql.sql with this syntax: mysql -uroot -ppassword < create_mysql.sql

and it gives the error:

ERROR 1044 (42000) at line 1: Access denied for user 'root'@'localhost' to database 'mangos'

Why is root unable to have access to something? it doesn't make any sense.

Link to comment
Share on other sites

this is easy that import script is not for sql it is a bash script, ran into the same problem first time as well, you have to run from git bash, I will try to link you to the tutorial or retrieve it for you

the zero project site seems dead I will try to explain it, until I can upload it somewhere

you have downloaded the database somewhere you will need to right click on that folder that contains the data base, select gitbash here

then type in mysql_import

assuming the setting are correct in mysql_info it will set everything up

this is for window but there should not be much difference in the process

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use