Jump to content

[SOLVED] Error compiling on FreeBSD


Guest manofwar95
 Share

Recommended Posts

in dep\\ACE_wrappers\\ace\\config-freebsd.h you will need to add lines

#define ACE_LACKS_GETHOSTBYADDR

#define ACE_LACKS_NETDB_REENTRANT_FUNCTIONS

at the top of the file

If this works then that's great, but if for whatever reason it doesn't I'll share what I did to fix my compile.

I copied dep/ACE_wrappers/ace/config-freebsd.h to dep/ACE_wrappers/ace/config.h and added

#define ACE_HAS_MEMCPY_LOOP_UNROLL

to it, and it worked when i rebuilt everything.

By the way there was also a problem with compiling VMaps on FreeBSD for me, it took me a very long time to fix this and I'm not exactly sure which trick I did that actually worked, but I think that it was by editing contrib/vmap_extractor_v3/vmapextract/CMakeLists.txt under "LINK_DIRECTORIES" to put the full directory to libmpq. This would be something like changing

LINK_DIRECTORIES( ${LINK_DIRECTORIES} ../../../dep/libmpq/libmpq/.libs/ )
to
LINK_DIRECTORIES( ${LINK_DIRECTORIES} /home/froid/Documents/mangos-one/dep/libmpq/libmpq/.libs/ )

If that fails I would try adding the path to your libmpq binaries in csh (ex: setenv LD_LIBRARY_PATH ${LD_LIBRARY_PATH}:/path/to/libmpq}

Link to comment
Share on other sites

in dep\\ACE_wrappers\\ace\\config-freebsd.h you will need to add lines

#define ACE_LACKS_GETHOSTBYADDR

#define ACE_LACKS_NETDB_REENTRANT_FUNCTIONS

at the top of the file

If this works then that's great, but if for whatever reason it doesn't I'll share what I did to fix my compile.

I copied dep/ACE_wrappers/ace/config-freebsd.h to dep/ACE_wrappers/ace/config.h and added

#define ACE_HAS_MEMCPY_LOOP_UNROLL

to it, and it worked when i rebuilt everything.

By the way there was also a problem with compiling VMaps on FreeBSD for me, it took me a very long time to fix this and I'm not exactly sure which trick I did that actually worked, but I think that it was by editing contrib/vmap_extractor_v3/vmapextract/CMakeLists.txt under "LINK_DIRECTORIES" to put the full directory to libmpq. This would be something like changing

LINK_DIRECTORIES( ${LINK_DIRECTORIES} ../../../dep/libmpq/libmpq/.libs/ )
to
LINK_DIRECTORIES( ${LINK_DIRECTORIES} /home/froid/Documents/mangos-one/dep/libmpq/libmpq/.libs/ )

If that fails I would try adding the path to your libmpq binaries in csh (ex: setenv LD_LIBRARY_PATH ${LD_LIBRARY_PATH}:/path/to/libmpq}

Thanks! This worked!

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use