Jump to content
  • 0

Retrieving item info with non-custom item in DB



So this week out of boredom I've compiled the latest repo on my home server running Ubuntu Server 12.10. I then downloaded the 4.3.4 torrent from this post: http://getmangos.eu/bb/topic/371/torrent-getting-all-clients/. After that I used the win32 tools from the repo to extract the dbcs, maps, and vmaps. I pulled the latest repo of the DB and set it all up in mySQL and ran the server. No issues. Opened up the client and created a new warlock. I leveled him to 85, and then went to add some of the gear I never saw in Cataclysm. I was able to add all of the DS Heroic items, but when I tried to add the legendary item: Dragonwrath, Tarecgosa's Rest (item ID: 71086), I get the item icon, and even the physical model when I equip it on my character, but the tooltip says Retrieving Item Info. In a lot of frustration, I have tried the following things to troubleshoot this issue:

  • Running an SQL query to ensure that the item is indeed in my world DB. It is.
  • Clear the Cache folder in my Wow folder. No change.
  • Check the client to make sure it isn't missing anything. It was listed on the forums so as far as I can tell it's the completed 4.3.4 client.

I'm confused and wondering what is causing the problem, and if it's something that I can fix. Thanks for reading, and I look forward to any help on the matter! And yes, I did spend some time looking around the forums (to include the old archive) before I posted this. I tried Google searches as well before someone suggests that.

P.S. As a matter of possible interest, I have also been testing TrinityCore 4.3.4 (though your core seems to be working much better!!) and using the same client on TrinityCore doesn't have an issue with the same item. Is that weird to anyone else? Meh.

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

No errors on the server side. And I have added a crap ton of items from patch 4.3 without similar problems. Also, on a random note, I am unable to get reforging to work. I searched all over the place while I was waiting for a reply here and there doesn't seem to anybody else asking about it. Does reforging not work? I appreciate your help :D Thanks.

Link to comment
Share on other sites

It sounds like some model/display id's could be off slightly, I will have i look hopefully later, if not tomorrow.

Just to clarify things for me, was this item already in the db or did you add it ?

- If you did add it, can you provide me with the SQL to add it to my db so I can test ?

As for reforging, I don't think it is currently working.

Could you check http://github.com/mangos/server/issues and raise an issue if its not already there ?

Link to comment
Share on other sites

Upon more testing, I am pretty much able to add any legendary in the DB except for these 3. I am wondering if it may have something to do with them being quest rewards, but I can't imagine why. I have no idea where in the code to look, I have a decent bit of C++ experience on both Windows and Linux, if anyone has any starting points. Thanks.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use