Jump to content
  • 0

Windows and Linux, a difference ?



Hi !

I now (since two days actually) a problem.

I have a server on which I added commands. My core was old and dated for about 2 years.

So I wanted to update and still have my commands and additions that I made above.

So I grabbed the sources of new MaNGOS on the official repositories, I've compiled and added my changes, I compiled again and everything goes well.

Therefore follows the testing phase involved :

Everything works perfectly on Windows, but when I tested these same sources compiled without errors on Linux, I get the following output when I try to run the following commands:

Table `command` have nonexistent command #mycommand, skip

Where is the problem, how to resolve it, do you have some clue?



Link to comment
Share on other sites

11 answers to this question

Recommended Posts

Linux and Windows are just operating systems. Your problem lies within your database on the Linux host. I would start with your world database. Specifically, the commands table. Make sure it is correct there. Also, if you added code to your core, you have to re-add that code after updating.

Link to comment
Share on other sites

Yes, I've made all the updates needed.

I've recently check my database and I imported the windows database (those one wich worked) but ... same error.

I've erased my mangos database and only implement the full_mangos wich is in the git package and ... same error too.

I don't know where to search to fix it.

Maybe this is my sources but it compile and I've check many times.

Link to comment
Share on other sites

For example, I followed the instructions in this patch and I applied by hand on files.

Link of patch

In the game, no change is made, the command .gob del tells me to specify a guid of a game object then it should work as follows:

I order .gob tar, it tells me a game object. The core keeps this object in "memory" and if I do the .gob del command right after, he understands that this is the last game object to delete.

My second problem (which I think is related to the first because similar) is the application of this patch, special commands:

Same here, I have all applied by hand, adapting any compilation errors.

It is on these commands I error : Table `command` have nonexistent command confrerie, skip

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use