Jump to content

Zero and Two, one realmd process?


Xenithar
 Share

Recommended Posts

Got a minor problem here. I have a Zero server and a Two server running on my Linux box. I have the realmd process from Zero running since it has always been up. I can connect and play Zero from any computer on my LAN. However, connecting from the Lich King client results in an error about being unable to connect. Do I need to run two separate realmd processes and if so, how can I do this?

Link to comment
Share on other sites

You will need only one realmd database, to keep all accounts for both servers in one place. So you only need one realm conf and realmd.exe.

You will have two mangosd.conf files. In the mangosd.conf settings, make sure "bind IP" points to the machine where your servers are running. However, change the ports. If server 1 is running on the default port of 8085, set server 2 to use another port like 8086. Be sure to set "realmID" so each world is different. Also make sure that "setrealm" indicates the correct client expansion in each conf file.

Be sure your world and characters databases are named differently for each server and edit their name and port numbers in the configs to match the servers.

If you use AHBot or Playerbot, edit the confs for those, too! You will have two of each.

Since you only need one realm login server, start everything in the order of realmd.exe, mangosd.exe for server 1, mangosd.exe for server 2.

That should have everything working. Just pay attention to detail when naming the databases and configuring the ports each world will use.

Link to comment
Share on other sites

I did this exactly as said, but it does not work. I actually have Zero set to port 8085 and Two to port 8086 listening on all interfaces, which is fine. However, when I only used one realmd process, the Lich King client would not connect to it. I will try again later, but for now I have Zero's realmd process listening on the primary adapter (eth0) and Two's realmd process listening on the aliased secondary adapter (eth0:0). Works fine this way, but I'd like to have one realmd process if possible to simplify things.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use