Jump to content
  • 0

Db_version too new?



So, I'm almost finished with creating a Mangos Zero server, but the problem I'm facing is that when running mangosd.exe it's telling me that I have an "out of date" version of the database. It says that I have 2007_18_Deadmines_Mr_Smite_Corrections.sql and I need 2007_01_Rel20_Release_Prep.sql. I'm not sure what to do.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

I'm having exactly the same problem. I freshly checked out both the server source and the database scripts. I used branch release20 on both. To be absolutely sure: The commit ids are 3c0355f5d6efa9ca674eeadb614c84cc9cf0d515 and a74238504f5b09b1b20cd67c4d168ec0e8a247ab respectively.

I started from an empty database, which I populated with these commands:

cat World/Setup/mangosdCreateDB.sql | mysql
cat Realm/Setup/realmdLoadDB.sql | mysql realmd
cat World/Setup/mangosdLoadDB.sql | mysql mangos
cat Character/Setup/characterLoadDB.sql | mysql characters

That should bring everything to the required versions, right? The files in */Updates are only for migrating an existing database, not for creating a new one, correct?

Link to comment
Share on other sites

Ok, this is what I tried since:

Delete the source folder, check out again, rebuild mangos -> same result

Populate the database using full_db.sql created by make_full_WorldDB.sh -> same result

What am I doing wrong?

edit: Or is mangos20 just too old, should I try mangos21 instead?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use