Jump to content
  • 0
alchemink

mangos zero Realm Loop on LAN/External

Question

Building ServerZero on Windows 7 machine.

Hey! New to all this and want to start off by saying thanks to those who put together all the guides! I had hangups here and there (mostly from this being my first time doing anything like this), but I was able to get through them. And my apologies in advance if I missed something obvious or missed a step in the guide...

So here's my problem: I got through the guide, got everything built. realmd.exe and mangosd.exe both run fine. I was able to create accounts no problem. Launching game from the host computer allows me to log in, choose a realm, create characters, and play the game. All good! However, whenever I try to connect over my LAN, it gets stuck on the realm select. Login is fine - goes right through.  It sees the realm, shows the correct character count (from characters made earlier in testing from host computer), but will NOT join the realm. Loops back to realm select. I have tried everything I could find on these forums. I made sure the realmd.realmlist has my external IP (goal is external) in 'address', and my host computer's internal IP in 'localAddress'. I know it doesn't matter for LAN, but I also made sure my router is forwarding ports 3724 and 8085 to the host computer's IP.

What I have tried:

  • Windows Firewall is disabled
  • UAC is disabled
  • ran the server exe files as Administrator
  • changed realmd.realmlist 'address' to Internal IP for testing on LAN (still loops); that is now changed back to External IP as instructed
  • Disabled router firewall (for testing; didn't fix, re-enabled)
  • Changed realmd.realmlist 'localAddress' to 127.0.0.1

I'm at a bit of a loss here. Not sure what else to check. Is there a permissions thing? Something in the .conf files I need to change? Could there be something in my router getting in the way? TPLink Archer C7 v.4.0, if it matters.

Thanks for any help or ideas people can offer!

Attached image of my realmd.realmlist table. External IP covered for security, of course.

 

realmd_address.PNG

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi, do you see any connection attempt on the realm process ? I feel like there's something wrong on the network configuration.

Is the realmd process authorized in your Windows firewall ?

Tal'

Share this post


Link to post
Share on other sites
  • 0

New user here with same realmlist loop problem.

Hopefully i'm not necroposting, but i could reply regardless (i.e. there's no expiration/grace period to be able to reply).

 

 

Anywho. I've set-up MaNGOS Zero for 1.12.1 WoW and forwarded/opened all the required/mentioned ports (they can be accessed from outside).

 

What i'm confused with is that i'm unable to verify if i did everything correctly, database related.

 

I use HeidiSQL and for some reason i see two seperate views that are related to the realmlist, but both views don't seem to share the same variables (see attached pictures).

 

Because of this i'm confused and not sure where i'm supposed to change/set the correct values.

database2.png

database1.png

 

Thanks for any help offered.

 

/copyitright

Edited by [email protected]!c

Share this post


Link to post
Share on other sites
  • 0

Wait.. the second view is the table structure, don't touch that :)

First image is the data table with the record to be updated. Update the "address" field with your public IP and it should be exposed.

Share this post


Link to post
Share on other sites
  • 0

I have the same issue and this is still not working. I've updated address/localaddress in the realmd realmlist data table. Everything is running fine. I've forwarded ports and even tried leaving everything open on firewall. I get to realm selection and stuck at "connected". 

I don't understand what I'm doing wrong, I feel like I'm at my wits end with mangos. :/ 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Contact Us

To contact us click here
You can also email us at [email protected]

Privacy Policy | Terms & Conditions

Repositories

The Link to the master list
of MaNGOS repositories:
Copyright © getMaNGOS. All rights Reserved.

This website is in no way associated with or endorsed by Blizzard Entertainment®
×
×
  • Create New...