Jump to content
  • 0

Help me with some basic instructions about how i can change the cli


Auntie Mangos

Question

Hi there MaNGOS community.

I was investigating MaNGOS project for a while and i am interested in it. Before long time ago i was writing some patches.

I am interested in the deal of changing the core patch version. Can you tell me how i can make it, i mean do not explain me C++ or something.

I know how to read/write on C++/PHP/Java but i need little help with the communication between the game and the core.

Can someone explain me what i must do if i want to change the core patch version to different. How can i sniff opcodes data ?

I know for that i need an active retail account and i have such, i know that i must know how to code in C++ and i can do that i just need some basic info that will help me a lot!

I am sure that if you help me i can help the MaNGOS project a lot.

Thanks in advance

Link to comment
Share on other sites

15 answers to this question

Recommended Posts

Hi there MaNGOS community.

I was investigating MaNGOS project for a while and i am interested in it. Before long time ago i was writing some patches.

I am interested in the deal of changing the core patch version. Can you tell me how i can make it, i mean do not explain me C++ or something.

I know how to read/write on C++/PHP/Java but i need little help with the communication between the game and the core.

Can someone explain me what i must do if i want to change the core patch version to different. How can i sniff opcodes data ?

I know for that i need an active retail account and i have such, i know that i must know how to code in C++ and i can do that i just need some basic info that will help me a lot!

I am sure that if you help me i can help the MaNGOS project a lot.

Thanks in advance

Link to comment
Share on other sites

Hello Antz and thank you for you help.

I have the current version from the official and active account there. I want to know how change the core client version to connect with this version 5.1.0 to the core. I mean i want to know how i can make the core accepting connections from this version.

I know that i must change the opcodes but how can i sniff them ? What else i must change?

Thanks in advance!

Link to comment
Share on other sites

Hello Antz and thank you for you help.

I have the current version from the official and active account there. I want to know how change the core client version to connect with this version 5.1.0 to the core. I mean i want to know how i can make the core accepting connections from this version.

I know that i must change the opcodes but how can i sniff them ? What else i must change?

Thanks in advance!

you need to change opcodes, new dbc struc, new update fields, new encrypt and decrypt and and and is a lot of work what you need done befor you can login wehn you have this done you need object update movement update for world login.

Link to comment
Share on other sites

Thank you so much!

Two other questions:

1. The branch of mangos for version 5.1.0 is available to login and the the current stage?

2. Is there any chance i get banned from blizzard if i use the WoWPacketParser to sniff data from their servers?

Thanks in advance!

Link to comment
Share on other sites

Thank you so much!

Two other questions:

1. The branch of mangos for version 5.1.0 is available to login and the the current stage?

2. Is there any chance i get banned from blizzard if i use the WoWPacketParser to sniff data from their servers?

Thanks in advance!

1) In a word no, the opcodes need to be configured

2) If you are caught there is a chance, you may be able to plead ignorance

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use