Jump to content
  • 0

[Three] extracting vmaps for 4.3.4


tweex15

Question

It seems another user had this same issue but I didn't see an actual solution to create the vmaps:

http://community.getmangos.eu/index.php?topic=18557.msg148763#msg148763

I'm having the same issue as the vmapExtractor.exe will populate the buildings folder with 10k or so files, but won't touch the vmaps. (see attached screenshot.)

This time around I downloaded the 4.3.4 client from the torrents found in the FAQ section here. All commands run on Win8 cmd as administrator.

Is there a solution?

Thank you!

[attachment deleted by admin]

Link to comment
Share on other sites

Recommended Posts

I'm using the extractor that came in the contrib directory after I pulled data down using Git. Was I supposed to compile one instead? I'm using this guide for most part: https://github.com/mangoswiki/Wiki/wiki/windowsinstallvm

Cheers

No, you were not supposed to. But it could be that the source of the extractor that came with the repo was changed after it has been built. In other words: the code has been changed but the extractor hasn't been recompiled afterwards. This is just an assumption since I'm not familiar with the workflow. I think it's worth a try.

Oh, and compile in release mode, not debug. (Just in case ::) )

From what I can tell, this is normal. I got the same thing and so far my world seems very playable.

That could be because Vmaps aren't necessary for the server to run. I guess your vmaps folder isn't empty?

Same for tweex15: Is your vmaps folder empty after the extraction process?

Link to comment
Share on other sites

That could be because Vmaps aren't necessary for the server to run. I guess your vmaps folder isn't empty?

Same for tweex15: Is your vmaps folder empty after the extraction process?

I will check when I get home. I thought my vmap folder wasn't empty though.

Link to comment
Share on other sites

No, you were not supposed to. But it could be that the source of the extractor that came with the repo was changed after it has been built. In other words: the code has been changed but the extractor hasn't been recompiled afterwards. This is just an assumption since I'm not familiar with the workflow. I think it's worth a try.

Oh, and compile in release mode, not debug. (Just in case ::) )

That could be because Vmaps aren't necessary for the server to run. I guess your vmaps folder isn't empty?

Same for tweex15: Is your vmaps folder empty after the extraction process?

Yes after the process is done my vmaps folder is completely empty. What was the purpose of the vmaps if they are not required?

Link to comment
Share on other sites

Well for now I'm doing what the original thread said and turned off vmaps. Now I've gotten as far as configuring the .conf files and noticed that my realmd database is completely empty. Looked over that Wiki guide and I don't see one part where it mentioned importing anything into that database. I must be some kind of dense... or that wiki is a bit outdated. Most likely the former.

Any idea what I could have missed?

Link to comment
Share on other sites

import the realmd.sql from server\sql\realmd.sql

/facepalm thank you for that.

It's all starting to come back to me bit by bit here. The next issue I swear I had at one point years ago:

In the game client I can connect to the mangos server, and see the name of the realm on the realm selection screen, but every time I hit "Okay" the popup "Logging in to game server" pops up for a couple seconds then just returns me to realm selection screen.

I figure the connection to mangos server isn't issue as I can see the name of it on the selection screen. Anyone had this happen to them?

Thanks for all the help thus far

Link to comment
Share on other sites

interesting, I ran my extractor on windows 7 and my vmaps is full, ran without problems, but I did have serious issues when I ran it with the enGB version thats floating in the torrents. I just pulled a fresh 4.3.4 enUS version using my original WOW dvd, then set the update using the how-to found in the stickies so now I have now have a enUS version that works fine, server installed and ran without issues (well one issue, but that was an issue of missing sql files from the git pull but was remedied quickly)

as for the no connect, make sure your conf (both mangos and realm config files) have the bindIP set to correct IP address also, and the realmd is configured, I at first thought it was a firewall issue also, spent several hours going through and trying various things only to find out it was a bindIP issue all the time, once those were set properly everything popped up and ran fine.

Link to comment
Share on other sites

interesting, I ran my extractor on windows 7 and my vmaps is full, ran without problems, but I did have serious issues when I ran it with the enGB version thats floating in the torrents. I just pulled a fresh 4.3.4 enUS version using my original WOW dvd, then set the update using the how-to found in the stickies so now I have now have a enUS version that works fine, server installed and ran without issues (well one issue, but that was an issue of missing sql files from the git pull but was remedied quickly)

as for the no connect, make sure your conf (both mangos and realm config files) have the bindIP set to correct IP address also, and the realmd is configured, I at first thought it was a firewall issue also, spent several hours going through and trying various things only to find out it was a bindIP issue all the time, once those were set properly everything popped up and ran fine.

Well I tried the bind IP settings in the realmd and mangos conf files, unfortunately no dice for my game client :(

I turned up the logging on the realmd and the attached photo shows what pops up every time I hit Okay on the realm selection screen. It prints this twice for every click. Hopefully that tells something... :)

[attachment deleted by admin]

Link to comment
Share on other sites

Not sure if this works the same in Windows as it does in linux, and assuming you are using Mysql.

Before you updated realmd.realmlist IP...did you stop the server. Update the realmd.realmlist IP to your Internal IP of the computer?

Then restart your mySQL? then restart your server. Be sure to set your BindIP in realmd.conf/mangosd.conf to your internal IP of the computer hosting the server.

If all that fails....firewall disabled?

Urlryn

Link to comment
Share on other sites

I have tried the bind IP once. Nobody could connect to the server after that.

I would retry it without bindIP (leaving it blank). If I recall it correctly you had "0.0.0.0" set in bind IP perhaps that was the issue all along? Couldn't it be that the server actually bound the IP to 0.0.0.0?

Link to comment
Share on other sites

@tweex15 have you changed the ip in the database aswell? It's located in realmd.realmlist and the field to change in that table is address

So I did what you said and changed the bindIP in the database, and when I tried from home it cruised right in to the character creation screen. Unfortunately I had to run to work so I didn't go any further, but I'm trying the client remotely and it's back to the same issue. I'll have to check when I get home to see if the home PC still works or not. Would be pretty random if it worked for just once and then not.

Link to comment
Share on other sites

@Svarr, binding to ip 0.0.0.0 should accept incoming connections to anywhere or how one would put it, ie: it should accept a connection if it came to 192.168.1.1 or 192.168.1.2 if those ip's go to the same server.

Alright, didn't know that. ::)
Link to comment
Share on other sites

What exact ip did you set it to in the db tweex, an internal one? Localhost? External? If you're running the server on the same machine as you are running wow you could set the address to 127.0.0.1, localhost or your internal ip that your router gives you, something along: 192.168.1.139 or so. If you want to connect from a computer connected to the same lan you would need to use the internal address given by your router, ie: 192.168.1.139 or so. If you're hosting externally you would need to set it to your external ip (whatismyip.com will help you finding that out) and then port forward the necessary ports to point at your computer hosting the server. Hope this is of any help!

Edit: The conf can be 0.0.0.0 but try changing what you have in the db :)

Link to comment
Share on other sites

What exact ip did you set it to in the db tweex, an internal one? Localhost? External? If you're running the server on the same machine as you are running wow you could set the address to 127.0.0.1, localhost or your internal ip that your router gives you, something along: 192.168.1.139 or so. If you want to connect from a computer connected to the same lan you would need to use the internal address given by your router, ie: 192.168.1.139 or so. If you're hosting externally you would need to set it to your external ip (whatismyip.com will help you finding that out) and then port forward the necessary ports to point at your computer hosting the server. Hope this is of any help!

Edit: The conf can be 0.0.0.0 but try changing what you have in the db :)

Hmm I don't have a static IP on my connection, I just use dyndns. But 0.0.0.0 in the db won't work?

Link to comment
Share on other sites

Not sure anybody asked yet.....

Have you configured your port forwarding in your router/cable modem/firewall?

forwarding port 80 to the server hosting your wow web page setup (if ya have one)

forwarding port 8085 to the wow server....This is the Mangos world server port. (So players can enter your realm)

forwarding port 3724 to the wow server....This is the realm server port (so players can see the realms in the realmlist)

Hosting to the outside....this is going off when i used to host a server...so my information maybe wrong now.

I thought you needed to change the realmd/mangosd conf files to be your public IP address. ( ipchicken.com will show you this)

Though leaving it like they said to 0.0.0.0 sounds like it should work.

Urlryn

Link to comment
Share on other sites

Not sure anybody asked yet.....

Have you configured your port forwarding in your router/cable modem/firewall?

forwarding port 80 to the server hosting your wow web page setup (if ya have one)

forwarding port 8085 to the wow server....This is the Mangos world server port. (So players can enter your realm)

forwarding port 3724 to the wow server....This is the realm server port (so players can see the realms in the realmlist)

Hosting to the outside....this is going off when i used to host a server...so my information maybe wrong now.

I thought you needed to change the realmd/mangosd conf files to be your public IP address. ( ipchicken.com will show you this)

Though leaving it like they said to 0.0.0.0 sounds like it should work.

Urlryn

Yes I did forward those ports in my router. I can 'see' the realmlist which is a good sign, and my realmd console log shows me authenticating, but that's about as far as get.

Link to comment
Share on other sites

Not sure if this means anything to anyone but I've tested a few different IPs for the realmlist IP in the DB.

-If I set it to 0.0.0.0 and click Okay on the realmlist I get put back to the same screen instantly

-If I set it to the server's IP and click Okay on the realmlist it freezes the client for a good 15 seconds then throws me back.

-If I set it to the stock 127.0.0.1 and click Okay on the realmlist I get a 1-2 second freeze and same result.

A bit strange that these variables are affecting the client like that. Now if I can find what I'm doing wrong so it'll actually let me in, I'd be golden.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use