Jump to content
  • [ZERO REL19] How to activate SOAP for the compilation

    • Status: Completed
      Main Category: Core / Mangos Daemon
      Sub-Category: Minor
      Version: 0.19 Milestone: 20-newbeginnings Priority: Normal
      Implemented Version: 0.20(currentmasterbranch)

    [ZERO REL19] How to activate SOAP for the compilation

    Hey Mangos!

    I got the 0.19 compiled again on linux, but when I start the server there is the following message:

    mangos>SOAP is enabled but wasn't included during compilation, not activating it.

    At cmangos it was included by default.
    How can I include this again?

    I tried -DSOAP=1 already. Did nothing change but crashes the mangosd

    When I used cmake again, it even doesn't show any options for SOAP

    root@someserver:/home/mangos/mangoszero/server/_build# cmake ../ -DSOAP=1 -DCMAKE_INSTALL_PREFIX=/home/mangos/mangoszero/stormrage/

    This script builds the MaNGOS server.
    Options that can be used in order to configure the process:
    CMAKE_INSTALL_PREFIX Path where the server should be installed to
    PCH Use precompiled headers
    DEBUG Debug mode
    USE_STD_MALLOC Use standard malloc instead of TBB
    ACE_USE_EXTERNAL Use external ACE
    BUILD_TOOLS Build map/vmap/mmap extractors

    To set an option simply type -D

    User Feedback

    Recommended Comments

    Seems we lost that change somewhere along the road, it's now included in Rel20 which you can pull and compile to get soap in, otherwise you can edit CMakeLists.txt in the root folder and add something like:
    option(SOAP "enable soap or not" ON)

    Directly under the other option() calls.

    Link to comment
    Share on other sites

    Would you like to test the attached patch and see if it helps you? This solved the problem for me.

    You can apply it using git am or the like, see [url]https://ariejan.net/2009/10/26/how-to-create-and-apply-a-patch-with-git/[/url] for some more info or ask here if you have trouble applying it.

    Forgot to mention, it's intended for Rel20 as it seems i forgot the option() part in Rel19, sorry about that. But if you've got both the option() and the patch it should work as expected.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use