Jump to content
  • 0

Ubuntu 16.04 fresh install


Question

I am following the guide here ... https://www.getmangos.eu/wiki/documentation/installation-guides/guideslinux/installing-mangos-on-ubuntu-1604-lts-r20078/

I am running Ubuntu 16.04 and chose to install MaNGOS 3. I have tried this many, many times and it is always failing constantly with errors at different places, which I have managed to fix until now.

First of all, I thought that now everything was being done by a script, everything was going to be easy..... no... it is still accompanied by errors, and guides missing out vital stages.

All of my client files have been copied to my MaNGOS home directory.

Along the way, I noticed several typos and throughout the script which were either causing me errors or I had spotted during browsing the script. These were a clear indication that this script was never tested properly before being released and it would not have worked with these errors.

Here's the diff on a couple of these:-
 

<       INSTPATH="$ROOTPATH/fice"
---
>       INSTPATH="$ROOTPATH/five"
<         rm -f "$GAMEPATH/map-extractor"
---
>         rm -rf "$GAMEPATH/map-extractor"

As you can see, a typo where 'fice' should have been 'five' and also when removing a directory (recursively) it is missing the -r switch.

Anyway, these were easy fixes but now the real problems begin...

 

Everything appears to work fine until this point:-

The realm database has been created!The realm database has been created!
The characters database has been created!
The world database has been created!
The file "/home/mangos/three/src/database/World/Setup/FullDB/achievement_criteria_requirement.sql" was processed properly
The file "/home/mangos/three/src/database/World/Setup/FullDB/achievement_reward.sql" was processed properly
The file "/home/mangos/three/src/database/World/Setup/FullDB/areatrigger_involvedrelation.sql" was processed properly
The file "/home/mangos/three/src/database/World/Setup/FullDB/areatrigger_tavern.sql" was processed properly
The file "/home/mangos/three/src/database/World/Setup/FullDB/areatrigger_teleport.sql" was processed properly

...

Database update "/home/mangos/three/src/database/World/Updates/Rel21/Rel21_07_006_Populate_missing_GO_desc.sql" was successfully applied!
Realm Name: MaNGOS Three Server #1  Realm ID: 1
dirname: missing operand
Try 'dirname --help' for more information.

The sql files all appear to be created successfully but immediately afterwards there appears to be a problem with the dirname and this is because there is an issue with the find command. Running this directly on the command line gives me a permission denied :-

INSTGAMEPATH=$(dirname $(find /home -name "WoW.exe"| head -1 2>>/dev/null))

By this time I had re-run the whole getmangos script more than half a dozen times over a period of many hours and I couldn't be bothered to fix this so I just corrected it as follows:-

INSTGAMEPATH=$(dirname $(find /home/mangos -name "Wow.exe"| head -1 2>>/dev/null))

Oh and by the way note how I have changed the WoW.exe to Wow.exe as it appears in my client, and without this change the find command will return nothing.

Strangely, it will now ask your game path (again?), which I had to manually enter. I think this bit of the script needs some rework.


                                       lqqqqqqqqqqqqqqqqqqqqqWoW Game Pathqqqqqqqqqqqqqqqqqqqqqqqqk
                                       x Please, provide the path to your game directory.         x
                                       x Default:                                                 x
                                       x lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk x
                                       x x/home/mangos                                          x x
                                       tqmqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqjqu
                                       x               <  OK  >        <Cancel>                   x
                                       mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj

And then, this is when the script falls on its arse completely...

                                  lqqqqqqqqqqqqqqqqqqqqqqqqqqqSelect Tasksqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk
                                  x Please select the extractions to perform                           x
                                  x lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk x
                                  x x                      [*] 1  DBC and Maps                       x x
                                  x x                      [*] 2  Vmaps                              x x
                                  x x                      [*] 3  Mmaps                              x x
                                  x mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj x
                                  x                                                                    x
                                  tqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqu
                                  x                   <  OK  >          <Cancel>                       x
                                  mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj

As soon as you continue here, this is what appears on the screen...

Map & DBC Extractor
===================

No locales detected
cp: cannot stat '/home/mangos/dbc': No such file or directory
cp: cannot stat '/home/mangos/maps': No such file or directory
Logging usage: Log <message> <echo flag>
 Beginning work ....
Loading common MPQ files
Error open archive: ./Data/enGB/locale-enGB.MPQ

Error open archive: ./Data/enUS/locale-enUS.MPQ

Error open archive: ./Data/deDE/locale-deDE.MPQ

Error open archive: ./Data/esES/locale-esES.MPQ

Error open archive: ./Data/frFR/locale-frFR.MPQ

Error open archive: ./Data/koKR/locale-koKR.MPQ

Error open archive: ./Data/zhCN/locale-zhCN.MPQ

Error open archive: ./Data/zhTW/locale-zhTW.MPQ

Error open archive: ./Data/enCN/locale-enCN.MPQ

Error open archive: ./Data/enTW/locale-enTW.MPQ

Error open archive: ./Data/esMX/locale-esMX.MPQ

Error open archive: ./Data/ruRU/locale-ruRU.MPQ

 Reading liquid types from LiquidType.dbc...Fatal error: Could not read LiquidType.dbc!
There was an issue while extracting VMaps!

								  

 

I am almost at the point of giving up as it is one problem after another. 

  • No locales detected
  • Cannot locate the dbc or maps directory (these have not been created yet)
  • A scripting problem being highlight by the logging usage message
  • MPQ files!!!?? These have not been used in game clients for at least a couple of years! - I don't see this script ever working with current game clients.
  • Error reading .dbc files... (maybe because the dbc directory does not exist?)
  • An error extracting vmaps

I have been trying to install MaNGOS over a number of years now and I never successfully completed it as there are always errors, more errors, incorrect or missing instructions. Sometimes even to the point of disinformation. I then give up. Again it seems that there are a plethora of errors etc in this script but I am determined to get to the bottom of it this around.

I have gone quite a long way to investigate and report these errors and I would appreciate some help, please. If there is any further information you require, please ask.

 

I have just tried this again and thought that this may me working, but no......

 

Then out of desperation, I tried the ExtractResources.sh script. This script appears to be deceptive and when you think it is working away like a busy beaver, it is actually doing nothing.

One the screen it shows...

Tue 25 Jul 09:07:28 BST 2017: Start extracting data for MaNGOS
DBC and map files will be extracted
Vmaps will be extracted
Mmaps will be extracted with 1 processes

Tue 25 Jul 09:07:28 BST 2017: Start extracting data for MaNGOS, DBCs/maps 1, vmaps 1, mmaps 1 on 1 processes

Tue 25 Jul 09:07:28 BST 2017: Start extraction of DBCs and map files...
Map & DBC Extractor
===================

No locales detected
Tue 25 Jul 09:07:28 BST 2017: Extracting of DBCs and map files finished


Tue 25 Jul 09:07:28 BST 2017: Start extraction of vmaps...

However, after waiting for a few hours, I decided to check its progress. I could find no maps, mmaps, dbc's or vmaps anywhere, so I checked the log file getmangos.log and this is what it says...

2017-07-25:09:23:32 Extracting DBC and Maps
2017-07-25:09:23:32 DBC and Maps are extracted
2017-07-25:09:23:32 Copying DBC and Maps files to installation directory
2017-07-25:09:23:37 Deleting VMaps previously generated.
2017-07-25:09:23:37 Copying VMaps extractor
2017-07-25:09:23:37 Extracting VMaps
2017-07-25:09:23:37 There was an issue while extracting VMaps!

 

So all along it was doing nothing.

 

Once again, please help...

 

 

Edited by DaveJ61
Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
16 minutes ago, roadapathy said:

Hey all, which torrent are we suppose to use? Mine was enGB and I believe that didn't work. I think we need enUS.

Dropped you a private message. Keep in mind that Three is a very early Alpha and not a lot working in it. Some areas may be ok.

  • Like 1
Link to post
Share on other sites
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use