Jump to content
  • 0

[Three] Not quite ready to go yet (round 2)


Mephisto_VI

Question

Continued from http://community.getmangos.eu/index.php?topic=19827.0

Okay, patched to 15595, ran ad.exe, and got errors, then it crashed.

"Can't extract file: DBFilesClient\DeclinedWord.dbc"

"Can't extract file: DBFilesClient\DeclinedWordCases.dbc"

successfully extracted 331 DBC/DB2 files though.

got to: Using Locale enUS

Loaded MPQ files for map extraction:

./Data/World.MPQ

then "ad.exe has stopped working" window pops up.

Will check my windows error logs and see what tripped it.

Question is, do I need it to go further or can I proceed to the vmap extractions?

Link to comment
Share on other sites

18 answers to this question

Recommended Posts

You probably need to go further if it crashed, i might have had the same issue as you are having, will take a look and see if i can reproduce it. Iirc, it had something to do with my client not being fully downloaded, i tried another one and that seemed to work. You could try using regenerator with a wow 4.3.4 exe to get it fully downloaded

Link to comment
Share on other sites

okay, regenerator did not resume where it left off. looks like either im going to uninstall, reinstall, then manually patch up or just download a torrent of it. not sure what client i had as i installed from my retail discs initially. i assume full as i didn't know they had compressed.

Link to comment
Share on other sites

Looks like I need to be careful what my "cleanup" programs actually remove. I just tried the regenerator again, and this time it asked if I wished to resume. Looks like I need to get a bit at a time without running my cleaners. This will take a while, so lets go ahead and close this thread, and I will open (round 3) if and when I need to. Thanks all for the help so far, and for a WONDERFUL program! ;D

EDIT: Oh, forgot to ask until after I initially posted this reply: Where does it download the files to? I do play on another private server for the time being until I get my own up and running, so if it downloads over the current installation, I need to figure out how to get two installations on one hard drive so I can keep playing without potentially erasing the regenerator's progress each time I login on the (other) private server.

Link to comment
Share on other sites

Change the InstallPath value in your registry to a new directory, if you want to install various world of warcraft installations as described in this post. Be careful when you do changes to the registry!

This works fine if you install manually. I don't know whether this works for wow regeneration too. You have to test it.

Link to comment
Share on other sites

Okay, I will try that so I have an untouched backup/official (should I decide to go back to it and spend the money :P) copy as well.

On a side note, if this tells you how long ago it was I ran my own server locally, I found the old files for it. Ready for the revision number? 7144 lol

Link to comment
Share on other sites

Well, sorry this has taken so long, but I finally got the time to let it run to completion. Regenerator finished and said press enter to close, so I did, ran ad.exe, and it crashed. This time I was able to find the windows event and look at the error. Getting exception code 0xc0000374 for it, and trying to sort through the help resources that list what generally cause this. Anyone else come across this and find a solution? Failing that, can someone archive and mail me the 4.3.4 enUS files ad.exe would create?

Link to comment
Share on other sites

MangosExtractor seems to have run beautifully. Only changes I made to default options on it were source and extract to locations. AD2 popped up a console window and closed it before any text ever showed up on the screen, will try calling it manually from a console window and see what it says. Switches? I guess I need to find the documentation on it as I have no clue about what to put after it to run those. Can you provide them please so I can try it?

EDIT: Ok, trying to run the AD2 copy that I compiled is giving me some problems as it won't recognize a folder with spaces in the name for the input and I cannot figure out how to tell it correctly. Its the WoW folder itself. How would I input "World of Warcraft" for it?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use