Jump to content
  • 0

Mangosd not Start | error related with Map 0004331.map




i recently compile Mangos Zero without errors
but when i tried to start mangosd i get the next error:



ERROR:Map file '../data/maps/0004331.map' is non-compatible version (outdated?). Please, create new using ad.exe program.
ERROR:Correct *.map files not found in path './maps' or *.vmtree/*.vmtile files in './vmaps'. Please place *.map and vmap files in appropriate directories or correct the DataDir value in the mangosd.conf file.

i did extract maps dbc and vmaps with compiled extractors and no work, try whit extractors that i found in internet and no work 

my wow version is 1.12.1

My Maps, DBC, and Vmaps are located in 


Release are located in


and Conf files in


and my mangosd.conf is here:


RealmID = 1

DataDir = "../data"

LogsDir = ""

LoginDatabaseInfo = ";3306;user;passwd;realmd"

WorldDatabaseInfo = ";3306;user;passwd;mangos"

CharacterDatabaseInfo = ";3306;user;psswd;characters"

LoginDatabaseConnections = 1

WorldDatabaseConnections = 1

CharacterDatabaseConnections = 1

MaxPingTime = 30

WorldServerPort = 8085

BindIP = ""

i was tried put dbc, maps and vmaps into Etc folder and no work !

Plase anyone helpme ❤️

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0
25 minutes ago, madmax said:

Have you tried extracting the map files on windows and copying them over? They are both the same files extracted, if that is an option for you.

mm i tried extract in windows but with thridpart extractors

i should recompile extractors on windows with the same source 

and extract again correct?


  • Like 1
Link to comment
Share on other sites

  • 0
24 minutes ago, antz said:

Please note that extractors found elsewhere on the internet are unlikely to work with mangos.

Please you build the project, compatible extractors are also built. These are the ones that should be used.

i'll try to compile extractors on windows and extrac again!
Thank you


i'll a reply here if it is solve my problem!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use