Jump to content
  • 0

unable to extract maps from client 1.12.1


Go to solution Solved by Talendrys,

Question

Hello,  I'm having troubles extracting map data from the vanilla client 1.12.1   I moved all the extractors, and the Resource extractor script to the client folder,   run the script and after answering the question it just zips by and finishes.. nothing extracted...

So I decided to run the extractors individually,  and here is the output of map-extractor and vmap-extractor.   I have tried redownloading the client two other times from different sources and they come up with the same results..

map-extractor:

./map-extractor
  ________________________________________________

    For help and support please visit:            
    Website / Forum / Wiki: https://getmangos.eu  
  ________________________________________________
Selected Options:
Input Path: .
Output Path: .
Flat export: false
Extract dbc: true
Extract maps: true
        __  __      _  _  ___  ___  ___      
       |  \/  |__ _| \| |/ __|/ _ \/ __|  
       | |\/| / _` | .` | (_ | (_) \__ \  
       |_|  |_\__,_|_|\_|\___|\___/|___/
       DBC Extractor & Map Generator for MaNGOSZero
  ________________________________________________
Detected locale:
Loading archive .\Data\base.MPQ
Loading archive .\Data\dbc.MPQ
Loading archive .\Data\misc.MPQ
Loading archive .\Data\model.MPQ
Loading archive .\Data\sound.MPQ
Loading archive .\Data\speech.MPQ
Loading archive .\Data\terrain.MPQ
Loading archive .\Data\texture.MPQ
Loading archive .\Data\wmo.MPQ
Loading archive .\Data\patch.MPQ
Loading archive .\Data\patch-2.MPQ
 ___________________________________    

 Extracting client database files...
 Extracted 0 files


 Extracting maps...
Error: Cannot find Map.dbc in archive!

It creates the dbc folder but nothing is in there.

./vmap-extractor
        __  __      _  _  ___  ___  ___      
       |  \/  |__ _| \| |/ __|/ _ \/ __|  
       | |\/| / _` | .` | (_ | (_) \__ \  
       |_|  |_\__,_|_|\_|\___|\___/|___/
       Vertical Map Asset Extractor for MaNGOSZero
  ________________________________________________
  ________________________________________________

    For help and support please visit:            
    Website / Forum / Wiki: https://getmangos.eu  
  ________________________________________________
 Beginning work ....
Detected locale:
Loading archive .\Data\base.MPQ
Loading archive .\Data\dbc.MPQ
Loading archive .\Data\misc.MPQ
Loading archive .\Data\model.MPQ
Loading archive .\Data\sound.MPQ
Loading archive .\Data\speech.MPQ
Loading archive .\Data\terrain.MPQ
Loading archive .\Data\texture.MPQ
Loading archive .\Data\wmo.MPQ
Loading archive .\Data\patch.MPQ
Loading archive .\Data\patch-2.MPQ
FATAL ERROR: None MPQ archive found by path '.'. Use -d option with proper path.

 

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hello,

Ignore the fact that i have already extracted the stuff but do your folders look like this?

image.png.69b936df4ad1f3123ac5aadac2c1f0c4.png

Should have highlighted the wow.exe too

If not move the contents of tools to the same folder as wow.exe and then run ./ExtractResources.sh

Kind regards

Oscinu

Edited by Oscinu
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use