Jump to content

[Patch] Auction House Bot (Xeross' Branch)

Recommended Posts

So we don't need to run the sql file?

I though thats how the table got created in the sql database... all sql code worked fine.... just that row that must apear twice in their ...in overall

if you want to check out the procedure i've written:


Part 24 on page 2 .... you could re write the text at your convenience to put it here if you want as i wrote everything to be an installation also possible while creating your server

Link to comment
Share on other sites

  • Replies 717
  • Created
  • Last Reply

Top Posters In This Topic

Good help here. http://getmangos.eu/community/showthread.php?13676-Patch-Auction-House-Bot-(Xeross-Branch)&p=113215&viewfull=1#post113215 (page 2).

I don't get any messages when checking or applying the patch but it works. Maybe my version of GIT is the reason since it's an older Windows GUI version.

Compiled the latest core at the time of this posting with the patch applied and it seemed to work fine. If I don't update my post it's probably working once I run the updated server. I just hope AHBot buys items put up for auction this time, didn't work with my last core build.

Edit: Haven't tested selling but it worked with the latest core at the time I posted this.

Link to comment
Share on other sites

what is problem

me\\AuctionHouseBot.h(6): fatal error C1083: Cannot open include file: 'Config/ConfigEnv.h': No such file or directory

Read the previous posts next time before asking again (don't be lazy!) http://getmangos.eu/community/showthread.php?13676-Patch-Auction-House-Bot-%28Xeross-Branch%29&p=117837&viewfull=1#post117837

Link to comment
Share on other sites


It's due to recent box filtering added. I didn't add new config in ahbot.conf to disable it because this hack was intended to avoid any gold farm of theses special container (contained other items). I didn't remeber if in retail version the locked box was permitted... If you need i can add config to let you enable box selling.


Yes, recent change broke little thing i will push the new code in some minute.


- Just follow some guide you will be able to find in this BB.

- It's up to you to choose one correspond to your need. Mine is new and still need more testing. For the other i just can't say anything...

- Patch is done ad usualy, try this method http://getmangos.eu/community/viewtopic.php?pid=125843#p125843

- There is lotoff differences, so you have to wait i (or anyone else who know it) wrote the complete feature of new_ahbot branch.

Link to comment
Share on other sites

Just tried using the patch that is Under Review now and found something odd

from console

ahbot status


Items loaded for Alliance=542, Horde=542, Neutral=542. Total = 1626

however from MySQL

SELECT COUNT(*) FROM auction GROUP BY houseid

returns the values

220, 202, 120 //Total is 542

Tested under FreeBSD, MaNGOS Rev 10637, No other patches

Link to comment
Share on other sites

Hi there!

Can you people tell me if Part 24 needs any changes about the installation of the AHBot...

It was working perfectly when i wrote it ....about 7 month's ago... i just want to keep the information up to date


Thank you

Yeah it changed alot.. just read the posts from above :)

Link to comment
Share on other sites

cyberium's work for Auction House Bot has been submitted for review to include it in the standard core.

You may find the new topic in the under review section here: http://getmangos.eu/community/topic/15522/patchauction-house-bot/

Continued development, updates, and discussions are posted there.

That link is invalid. Is this addon still being updated?

Link to comment
Share on other sites

  • 40 years later...

I am currently not updating my branch and Cyberium continued development.

-> http://github.com/cyberium/mangos/tree/ahbot (stable one from xeross branch, just the no account modification on it)

-> http://github.com/cyberium/mangos/tree/new_ahbot many modification. Beta version of future integrated ahbot? :)

Author Information

Originally Created by ChrisK & Paradox

Buyer functionality was added by Kerbe and Paradox

After this the AHBot was maintained by Naicisum

And now I took over the maintenance/development until Naicisum returns and continues development

Current Release AHBot-x004

  • * Removed the need of a character (Thanks to Cyberium)
    * Added config option for AHBot name (Thanks to Cyberium)
    * Fixed seller/buyer so it works with all factions.

Previous Release AHBot-x003.03

Small bugfix with auction table

Previous Release AHBot-x003.02

  • * Updated to latest changes in the core
    * Various fixes including the pending sale mail now being sent
    * Numerous optimizations
    * Log filter system is utilized
    * Lots of additional debug output

Previous Release (AHBot-x002)

Added additional filtering options

  • * Min/Max ItemLevel
    * Min/Max Required Level
    * Min/Max Skill Level

Previous Release (AHBot-x001)

The first release by me, includes a better alternative to MinimalLoadFromDB, has renamed config options and has an additional function to reload the config options stored in the database.

Branch Overview

master - No modifications, direct replica of mangos/master

ahbot - The Auction House Bot branch

How to check out

git clone git://github.com/xeross/mangos.git ahbot
cd ahbot
git checkout -b ahbot origin/ahbot

How to create a patch (First check out as shown above)

git diff 4bbb824c8088d28d9736bea51edcda586c471901 ahbot > ../ahbot.patch

The patch will be called ahbot.patch and situated one folder above the mangos folder.

Config Options

There's numerous options configurable in the config, they can be found by searching for "AuctionHouseBot" in the config, explanation is included with them.

Next to these options there's also the database options, you need to have imported the auctionhousebot.sql to your character DB to have them (Which you should do anyways), and after that the options can be found in the auctionhousebot table, all the options are explained in the table itself and can also be configured from in-game.

Report any bugs or problems you find in this thread and I will try to get it fixed.

Link to comment
Share on other sites

But when i compile i get 2 errors o.O

========== Build: 11 succeeded, 2 failed, 0 up-to-date, 0 skipped ==========

running Mangos: rev. using db: PSDB WotLK (r304) for 3.3.3a (Core r9752 / SD2 r1671)

So where did i go wrong at ?

Okay there are 2 things that might've happened

1. The Incremental Linker crashed, this should be easily spotted as it would pop-up a windows crash dialog.

2. There's an error somewhere, check the error list in VS after compilation

Link to comment
Share on other sites

So, your fork now has its own home here in the Core Mods forum. You deserved to have it and a new thread will help to reduce some of the confusion, especially if Naicisum ever does return to the old AHBot topic. I'm very glad and thankful you were so good to help the community by accepting the extra responsibility of maintaining AHbot.

Good to see things are progressing and, hopefully, new ideas and suggestions will come pouring forth to help further improve the code.

I like the idea of having a patch file available from your AHBot repo. Perhaps this will reduce the long string of requests for patch files and simplify the process for those who need to hand-edit the patch into newer MaNGOS revisions. Well, maybe you can hope it will. lol

Keep up the great work, xeross! :)

Link to comment
Share on other sites

Just me or is the AH Buyer not buying for everyone else?? I've yet to get this to function despite everything that's been going on with AHBot lately...I've pulled a clean Mangos and followed the instructions in this thread...and yet the AH Buyer won't give up the gold! ;)

Link to comment
Share on other sites

Just me or is the AH Buyer not buying for everyone else?? I've yet to get this to function despite everything that's been going on with AHBot lately...I've pulled a clean Mangos and followed the instructions in this thread...and yet the AH Buyer won't give up the gold! ;)

After the last update the AHBuyer should be functioning again, make sure you have it enabled in the config, and configured properly in the database.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use