Jump to content
  • Auction house bot is broken...

    • Status: Completed
      Main Category: Core / Mangos Daemon
      Sub-Category: Item Handling
      Version: 21.3 Milestone: 20-newbeginnings Priority: New
      Implemented Version: 0.20(currentmasterbranch)

    No items being listed...

    AHBot appears to be broken. Nothing gets listed at this time and it appears to be ignoring items players put up for sale.

    User Feedback

    Recommended Comments

    Are you running the server inside a .bat file or as a service? I found on windows it can be broken when running under those.

    We have no developers with AHbot experience, the current idea is to rewrite it at some point, I think with an Eluna/lua based AH system.

    The AHbot system was looked at 6months ago when I first found it and no one wanted to look at it.

    Link to comment
    Share on other sites

    It worked in R19, it stopped working in R20. Also, a feature like this should not be ported to SD2 or LUA because those of us who use one or the other will lose a feature that has been in for years. Shouldn't we be able to locate the AHBot repo and pull from it? Without a working auction hall, it is very difficult to gain money, especially solo.

    That said, all of my servers are Linux. Each process runs on a dedicated console and I start it by hand. No scripts running any of the MaNGOS stuff on my end. I have been running a debug build in gdb (debugger), but I tried it without gdb and no change. Something broke when R20 came along. No clue as to what.

    Link to comment
    Share on other sites

    Alright, this is getting bad. It has become VERY difficult to (without using GM commands) keep cash for skills when levelling. What caused the AHBot to break in R20? I am assuming nobody changed the bot itself, so something else must have changed to cause the break. What was changed that would break the bot? I need to look into this.

    Link to comment
    Share on other sites

    Yeah but this is Linux, on a console, same way it has run for years. I don't start it with a script or anything. I just know it worked in R19 and does not work in R20, so I believe it is an issue in the code somewhere, but I need a starting point to even begin looking.

    Link to comment
    Share on other sites

    Check all the commits done to the AH bot files? :)


    Link to comment
    Share on other sites

    I was under the impression AHBot was not modified. This changes things. I will start with those. Thanks. I am also looking at the dang crash that happens all the time, but it appears to be with vmaps and I do not understand vmaps.

    Link to comment
    Share on other sites

    I looked and only saw ONE commit that appeared to be for R20, and it changed variable (constant?) names. The others are before I started having issues. The only recent one is linked below, but I do not see how this would cause the program to not work at all.


    Link to comment
    Share on other sites

    As of the latest changes to Rel20, SD2 is no longer compiled as a shared library, but a static library and integrated into the binary :) Thus the above comment is no longer "valid" and the issue should be re-tested if it indeed was SD2 related :)

    Link to comment
    Share on other sites

    Still no go. AHBot lists items when starting up but nothing is on the AH in game. Have their been any DB changes I may have missed that moved the location of the AH table(s)? I used a fresh AHBot config file and enabled both buyer and seller. Neither appear to be working. This is on 32bit GNU/Linux, external ACE, SD2 and Eluna compiled, the works. It is a debug build since I like to be able to provide backtraces in the event of a crash.


    Alright, I have a fresh world DB and character DB, both with ALL updates. Now, the AH is still empty. No clue why. Fresh configuration files and all.

    Link to comment
    Share on other sites

    My auction table exists in the character database, but it is empty. When MaNGOS starts, I see AHBot list a bunch of items, but they are never inserted into the database and no error is shown. Seems to be a core issue to me at this point. If it is unable to insert data it SHOULD post an error or warning to the output or log so we have something to go by.


    Players can post and buy items on the AH without issue. I put a piece of silver on there and it showed up in the DB instantly. It can also be viewed and purchased by others. So that seems to indicate that the core can work with the auction table, so why can't the bot?


    Alright, so I issued ".ahbot reload". This is what was logged on the server console and in the log-file.
    2014-10-26 22:21:21 AHBot seller filters:
    2014-10-26 22:21:21
    2014-10-26 22:21:21 Forced Inclusion 0 items
    2014-10-26 22:21:21 Forced Exclusion 0 items
    2014-10-26 22:21:21
    2014-10-26 22:21:21 Loading npc vendor items for filter..
    2014-10-26 22:21:21 Npc vendor filter has 1743 items
    2014-10-26 22:21:21
    2014-10-26 22:21:21 Loading loot items for filter..
    2014-10-26 22:21:21 Loot filter has 6886 items
    2014-10-26 22:21:21
    2014-10-26 22:21:21 Sorting and cleaning items for AHBot seller...
    2014-10-26 22:21:22 AuctionHouseBot seller will use 3608 items to fill auction house (according your config choices)
    2014-10-26 22:21:22 Items loaded Grey White Green Blue Purple Orange Yellow
    2014-10-26 22:21:22 Consumable 0 93 0 0 0 00
    2014-10-26 22:21:22 Container 0 21 1 0 0 00
    2014-10-26 22:21:22 Weapon 81 60 185 182 5 00
    2014-10-26 22:21:22 Jewelry(OBSOLETE) 0 0 0 0 0 00
    2014-10-26 22:21:22 Armor 227 200 1248 257 22 00
    2014-10-26 22:21:22 Reagent 2 24 6 2 0 00
    2014-10-26 22:21:22 Projectile 0 1 1 1 0 00
    2014-10-26 22:21:22 Trade Goods 2 158 39 11 3 00
    2014-10-26 22:21:22 Generic(OBSOLETE) 0 0 0 0 0 00
    2014-10-26 22:21:22 Recipe 0 12 275 63 14 00
    2014-10-26 22:21:22 Money(OBSOLETE) 0 0 0 0 0 00
    2014-10-26 22:21:22 Quiver 0 0 0 0 0 00
    2014-10-26 22:21:22 Quest 0 13 0 0 0 00
    2014-10-26 22:21:22 Key 0 2 1 0 0 00
    2014-10-26 22:21:22 Permanent(OBSOLETE) 0 0 0 0 0 00
    2014-10-26 22:21:22 Miscellaneous 278 83 2 33 0 00
    2014-10-26 22:21:22
    2014-10-26 22:21:22 AHBot seller configuration data loaded and initilized
    However, the auction table in the character database is empty and nothing is listed in-game.

    Link to comment
    Share on other sites

    I have one comment, it works fine on the TWO server ik can sel everything and i can buy also things it put on AH so it is filled with white green rare and also epic stuf, so i think it has to do something with the core maybe

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use