Jump to content
  • Creatures near thunderbluff walk in the air

    • Status: Completed
      Main Category: Database
      Sub-Category: Creature
      Version: 21.3 Milestone: 21 Priority: New
      Implemented Version: 21.3

    Creatures near thunderbluff walk in the air

    Hi. I'm currently using the develop21 branch.
    Outside of thunderbluff, in a precise spot (.go -1443.5 275.6 11.0 1) , there's an adult plainstrider that seems to have trouble finding where the ground is on that hill. Same thing with the nearest Flatland Cougar (though you might have to pull it a bit to the hill where the plainstrider is).
    Everything works perfectly around thunderbluff besides monsters on that hill and around it, it's very weird (sometimes some monsters around that spot even through the ground and can still attack you). Problem with the maps ?
    I've extracted all the maps/vmaps with the latest extractor provided in the develop21 branch, and this is the only spot in the game I've come so far with such glitch.

    User Feedback

    Recommended Comments

    This is a bug with either the vmaps creation or the server. I am experiencing this all over the place. Other symptoms will include mobs which aggro, then lose aggro, then repeat constantly, probably due to not being able to path to your player, despite being right next to you. Tanaris is a great place to see this issue in action. Get a hunter or warlock and TRY to keep the pet with you. They cannot even path over small dunes. So yes, either vmaps are broken during creation or the server-side code for handling mobs/pets is broken.

    I am not familiar with the vmap/movement code personally, but if this remains open when I finish my next set of fixes and PR it, I will look into it. Hopefully somebody more familiar with the movement code can sort it before then.

    Link to comment
    Share on other sites

    Reaper, I said vmaps/movement and MEANT to say mmaps/movement, thanks for the correction. I got separate tools the last time I built everything on my Linux box (assembler and extractor were separate) and this was Monday. I just now cloned the official repo, develop21, and can't even build the stuff due to an LUA make error. I am about to post this error in a ticket, but I believe the separate tools were bugged and I have bad mmaps, as this person probably does. Once I can try building the mmaps with the new, unified tool I expect the issue to go away.

    Link to comment
    Share on other sites

    Last night I cloned the latest d21 branch and built the new tools. I then re-extracted everything and it fixes about 90% of the movement issues with mobs. Some mobs still climb into the air, but hunter/lock pets can now follow the player and mobs can get to the player to fight, instead of standing in place and trying to enter combat repeatedly. My advice to the OP is to clone everything again, build again, and extract everything using the new tools. This should fix your problems.

    I will note that the new, unified tool does a good job, but I still get mobs going into the sky from time to time. I am not sure why, but it is still MUCH better than before, though a hair behind what we had a year ago. Perhaps we should make an option for creating better movement maps at the expense of disk space. Kind of like we have the option to make worse maps to save space (int vs float I believe).

    Link to comment
    Share on other sites

    I rebuilt everything, and noticed in the end that I already had those tools. Rebuilding didn't fix the issue of the flying creatures near thunderbluff I pointed out in my first message. I didn't quite got your previous message because I didn't have those problems with the pets, so I guess you weren't up to date :)
    As I said enabling or disabling mmaps doesn't change anything, so I guess it has nothing to do with them.
    There's few places in the world where enemies act like this. I'd suggest watching it by yourselves. I'm not at all used to do the movement coding in mangos, although I'm working on it, so I can't do much right now :/

    Link to comment
    Share on other sites

    any NPC will glitch around that spot near thunderbluff. I tried removing those that were buggy by other npcs already, and they just seem to struggle finding a path there. It's even possible to get them underground near the hill described in first post. Again, it's the only place I saw so far that produces this glitch.

    Link to comment
    Share on other sites

    Did you configure MaNGOS and point it to the correct directories and such? What you are describing sounds to me like the server daemon is not finding the movement maps. I cannot reproduce this with the current build. Did you copy the new mmaps directory into the correct location after building?


    Scratch that, I can now produce this issue with the maps created by the new tools. Things even go underground where the Darkmoon Faire is supposed to be. See attached pics.

    Link to comment
    Share on other sites

    Fixed [URL="https://github.com/mangos/Extractor_projects/pull/8"]with this PR[/URL]. After it's merged, the extractor tools must be rebuild and all maps/vmaps/mmaps reextracted. The issue can be closed.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use