Jump to content
  • 0

Question

Hello :)

I seem not to be able to kickstart AHbot.

I did duplicate the default ahbot.conf.dist file into a valid ahbot.conf, with seller and buyer enabled of course.

Then restarted mangosd.

Log still says "ahbot not enabled".

What am I doing wrong? :(

Thanks for continued help 

ciao

U

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

rename the file from .conf.dist to .conf

Share this post


Link to post
Share on other sites
  • 0

sorry I misread that, you say that you have enabled both.... in the conf ?

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, antz said:

sorry I misread that, you say that you have enabled both.... in the conf ?

yes. In the etc directory now I have an "ahbot.conf" file, where I have 

AuctionHouseBot.Seller.Enabled = 1

and

AuctionHouseBot.Buyer.Enabled = 1

 

Btw, I also left 

AuctionHouseBot.CharacterName  = ""

 

as the comments, above, say

#    Default "" (No owner)

 

Ciao

U

 

Share this post


Link to post
Share on other sites
  • 0

world-server.log tells me 

2017-05-21 18:25:59 Initialize AuctionHouseBot...
2017-05-21 18:25:59 AHBOT is Disabled. Unable to open configuration file ../etc/ahbot.conf. 
 

But the conf file is there, and with the right privileges...

 

Share this post


Link to post
Share on other sites
  • 0

Without me changing anything else, ahbot started working. Meaning, mangosd now "can" read ahbot.conf.

I must conclude that, previously, the conf file appeared busy by whatever other process.

Anyhow, solved (by itself) now :)

Share this post


Link to post
Share on other sites
  • 0

I got the problem again.

Yesterday I rebuilt the whole Zero thing to include playerbots.

After the rebuild, again I have

AHBOT is Disabled. Unable to open configuration file ../etc/ahbot.conf. 

in the world-server.log file

Needless to say, ahbot.conf staid there since before, nothing changed, no permissions changed etc etc

There seems to be no other process tampering with it.

Where's the catch??

 

Thanks

U

Share this post


Link to post
Share on other sites
  • 0

I think I found where the issue stays. Didn't solve it yet though.

 

After rebuilding, 

if I launch mangosd as a normal binary (./mangosd), ahbot.conf is properly read-in and all works

If I launch mangosd as a service (as I configured it earlier as per wiki instructions) ahbot.conf is NOT read-in !

 

 

Any clue how to fix this?

 

Thanks ciao

U

 

Share this post


Link to post
Share on other sites
  • 0

Maybe related to the -c option which gives only mangosd.conf.

There should be extra options for ahbot conf file.

Tal'

Share this post


Link to post
Share on other sites
  • 0

Sounds logical.

Yet, I am positive this *did* work, without -c option for ahbot.conf, as a service at least once before. Odd i'ni?

I'll try and add the -c opt and feedback here

 

ciao

U

Share this post


Link to post
Share on other sites
  • 0

And by the way, aiplayerbot.conf *is* loaded (in service-mode) without specifying it inside the service file, only ahbot.conf is not...

 

Share this post


Link to post
Share on other sites
  • 0

For now I suspended research on this. I'm launching realmd and mangosd as ordinary deamons, each one on its own Screen instance. 

Edited by iltuocapo

Share this post


Link to post
Share on other sites

Contact Us

To contact us click here
You can also email us at [email protected]

Privacy Policy | Terms & Conditions

Repositories

The Link to the master list
of MaNGOS repositories:
Copyright © getMaNGOS. All rights Reserved.

This website is in no way associated with or endorsed by Blizzard Entertainment®
×