Jump to content
  • 0

[CMake Error] SSL_EAY_RELEASE & LIB_EAY_RELEASE ?


Question

when ever i try to use the dev build, i get this error when i attempt to compile it.

also got the dev from: git clone https://github.com/mangosone/server -b develop21 --recursive

This script builds the MaNGOS server.
 Options that can be used in order to configure the process:
  General:
   CMAKE_INSTALL_PREFIX    Path where the server should be installed to
   CONF_DIR                Path to the configs, can be absolute or relative.
   DEBUG                   Debug mode (strict compile, all warnings)
   ACE_USE_EXTERNAL        Use external ACE
   BUILD_TOOLS             Build the map/vmap/mmap extractors
   SOAP                    Enable remote access via SOAP
  Scripting engines:
   SCRIPT_LIB_ELUNA        Compile with support for Eluna scripts
   SCRIPT_LIB_SD2          Compile with support for ScriptDev2 scripts
#   Modules:
#    PLAYERBOTS              Enable Player Bots
 To set an option simply type -D<OPTION>=<VALUE> after 'cmake <srcs>'.
 Also, you can specify the generator with -G. see 'cmake --help' for more details
 For example: cmake .. -DDEBUG=1 -DCMAKE_INSTALL_PREFIX=/opt/mangosNote:OnUNIXsystems,CONF_DIRisrelativetothebinfolder.

Detected 32-bit platform
CMake Warning (dev) at cmake/FindGit.cmake:36 (find_program):
 Policy CMP0053 is not set: Simplify variable reference and escape sequence
 evaluation.  Run "cmake --help-policy CMP0053" for policy details.  Use the
 cmake_policy command to set the policy and suppress this warning.

 For input:

   '$ENV{ProgramFiles(x86)}/Git/bin'

 the old evaluation rules produce:

   'C:\Program Files (x86)/Git/bin'

 but the new evaluation rules produce an error:

   Syntax error in cmake code at
     C:/Users/M91/Documents/GitHub/server/cmake/FindGit.cmake:40
   when parsing string
     $ENV{ProgramFiles(x86)}/Git/bin
   Invalid character ('(') in a variable name: 'ProgramFiles'

 Using the old result for compatibility since the policy is not set.
Call Stack (most recent call first):
 CMakeLists.txt:85 (find_package)
This warning is for project developers.  Use -Wno-dev to suppress it.

Found OpenSSL library: optimized;SSL_EAY_RELEASE-NOTFOUND;LIB_EAY_RELEASE-NOTFOUND;debug;SSL_EAY_DEBUG-NOTFOUND;LIB_EAY_DEBUG-NOTFOUND
Found OpenSSL headers: C:/OpenSSL-Win64/include
Found MySQL library path: C:/wamp/bin/mysql/mysql5.6.17/lib
Found MySQL library: C:/wamp/bin/mysql/mysql5.6.17/lib/libmysql.dll
Found MySQL headers: C:/wamp/bin/mysql/mysql5.6.17/include
MaNGOS-Core revision  : 66310dc6ff847ad841a81369eb6b9420e1c15287
Install server to     : C:/Program Files (x86)/MaNGOS
Install configs to    : C:/Program Files (x86)/MaNGOS/
Search configs from   : binary directory (default)
Support for SOAP      : Yes
Script engine Eluna   : Yes (default)
Script engine SD2     : Yes (default)
Build tools           : No
Build in debug-mode   : No  (default)
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
LIB_EAY_DEBUG (ADVANCED)
   linked by target "realmd" in directory C:/Users/M91/Documents/GitHub/server/src/realmd
   linked by target "mangosd" in directory C:/Users/M91/Documents/GitHub/server/src/mangosd
LIB_EAY_RELEASE (ADVANCED)
   linked by target "realmd" in directory C:/Users/M91/Documents/GitHub/server/src/realmd
   linked by target "mangosd" in directory C:/Users/M91/Documents/GitHub/server/src/mangosd
SSL_EAY_DEBUG (ADVANCED)
   linked by target "realmd" in directory C:/Users/M91/Documents/GitHub/server/src/realmd
   linked by target "mangosd" in directory C:/Users/M91/Documents/GitHub/server/src/mangosd
SSL_EAY_RELEASE (ADVANCED)
   linked by target "realmd" in directory C:/Users/M91/Documents/GitHub/server/src/realmd
   linked by target "mangosd" in directory C:/Users/M91/Documents/GitHub/server/src/mangosd

Configuring incomplete, errors occurred!
See also "C:/Users/M91/Documents/GitHub/server_build/CMakeFiles/CMakeOutput.log".

only thing i can think of, its because i'm trying to do it with a 64Bit of OpenSSL, i'll try it with a 32Bit.

also attaching the "CMakeOutput.log" had to rename it to .txt for it to upload.

[ATTACH]238[/ATTACH]

CMakeOutput.txt

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

was able to get it working by looking at the CMake cache file and editing it.

//Path to a library.
LIB_EAY_DEBUG:FILEPATH=C:/OpenSSL-Win64/lib/VC/libeay32MD.lib

//Path to a library.
LIB_EAY_RELEASE:FILEPATH=C:/OpenSSL-Win64/lib/VC/libeay32MD.lib

//Path to a library.
SSL_EAY_DEBUG:FILEPATH=C:/OpenSSL-Win64/lib/VC/ssleay32MD.lib

//Path to a library.
SSL_EAY_RELEASE:FILEPATH=C:/OpenSSL-Win64/lib/VC/ssleay32MD.lib

i have been following this(was the prob i was getting just after fixing the filepaths for openssl)

https://www.getmangos.eu/archived-help/9248-zero-mysql-related-unresolved-external-symbols-compiling.html

im now stuck on

Error	1	error LNK1107: invalid or corrupt file: cannot read at 0x2F8	C:\Program Files (x86)\MySQL\MySQL Server 5.7\lib\libmysql.dll	1	1	movemap-generator
Error	2	error LNK1107: invalid or corrupt file: cannot read at 0x2F8	C:\Program Files (x86)\MySQL\MySQL Server 5.7\lib\libmysql.dll	1	1	realmd
Warning	3	warning C4700: uninitialized local variable 'uGraveNumber' used	c:\users\m91\documents\github\server\src\modules\sd2\scripts\outland\hellfire_peninsula.cpp	1031	1	mangosscript
Error	4	error LNK1107: invalid or corrupt file: cannot read at 0x2F8	C:\Program Files (x86)\MySQL\MySQL Server 5.7\lib\libmysql.dll	1	1	mangosd

here is my Cmakecahce file referencing mysql

//Specify the directory containing mysql.h.
MYSQL_INCLUDE_DIR:PATH=C:/mysql-5.7.8-rc-win32/include

//Specify the location of the mysql library here.
MYSQL_LIBRARY:FILEPATH=C:/mysql-5.7.8-rc-win32/lib/libmysql.dll

//Specify the path to the mysql library (.lib) here.
MYSQL_LIBRARY_DIR:PATH=C:/mysql-5.7.8-rc-win32/lib/

should should be just about it for my errors, thank you all for helping.

Link to post
Share on other sites
  • 0

You shouldn't need to edit anything what so ever as long as the dependency installations for the platform you are building on is correct. If you select a 32 bit compiler during the cmake step, you need to have the 32 bit dependencies installed, vice versa for 64 bit.

From the above, you are pointing to 64 bit OpenSSL. The compile error shows you have 32 bit MySQL installed. What exactly are you trying to compile as, 32 or 64 bit?

Edited by Foereaper
Link to post
Share on other sites
  • 0

i had to edit the cmake cache, cmake & easybuild did not auto detect my installs.

im trying to build a 32Bit mangos server based on the dev from the github build.

i was able to install openssl 32Bit and change the path files in the cache file.

//Path to a library.
LIB_EAY_DEBUG:FILEPATH=C:/OpenSSL-Win32/lib/VC/libeay32MD.lib

//Path to a library.
LIB_EAY_RELEASE:FILEPATH=C:/OpenSSL-Win32/lib/VC/libeay32MD.lib

//Path to a library.
SSL_EAY_DEBUG:FILEPATH=C:/OpenSSL-Win32/lib/VC/ssleay32MD.lib

//Path to a library.
SSL_EAY_RELEASE:FILEPATH=C:/OpenSSL-Win32/lib/VC/ssleay32MD.lib

now i only get the two errors.

Error	1	error LNK1107: invalid or corrupt file: cannot read at 0x2F8	C:\mysql-5.7.8-rc-win32\lib\libmysql.dll	1	1	realmd
Warning	2	warning C4700: uninitialized local variable 'uGraveNumber' used	c:\users\m91\documents\github\server\src\modules\sd2\scripts\outland\hellfire_peninsula.cpp	1031	1	mangosscript
Error	3	error LNK1107: invalid or corrupt file: cannot read at 0x2F8	C:\mysql-5.7.8-rc-win32\lib\libmysql.dll	1	1	mangosd

[Edit]just deleted all the files i was working on, redownloaded the mangosone dev21 & ran easybuild and it worked for some reason.

25>------ Build started: Project: ALL_BUILD, Configuration: Release Win32 ------
25>  Building Custom Rule E:/WoW_TBC/dev/server/CMakeLists.txt
25>  CMake does not need to re-run because E:\WoW_TBC\dev\server_build\CMakeFiles\generate.stamp is up-to-date.
26>------ Skipped Build: Project: INSTALL, Configuration: Release Win32 ------
26>Project not selected to build for this solution configuration 
========== Build: 25 succeeded, 0 failed, 0 up-to-date, 1 skipped ==========

took me two full days of messing with everything, uninstalling/reinstalling lol guess sometimes it works to just delete the project files and redownload them.

Thank you everyone for your help with this. <3

Edited by TheDinggo
Link to post
Share on other sites
  • 0

ok, I've seen a couple of reports of this

As of yesterday there was no version of mysql 5.7, they had a 'glitch' on their server which tricked some systems into installing the rc for 5.7 before they fixed it.

- i would suggest removing 5.7

mangos doesn't currently support mysql above 5.6

Link to post
Share on other sites
  • 0

 

On 8/13/2015 at 7:01 AM, antz said:

ok, I've seen a couple of reports of this

As of yesterday there was no version of mysql 5.7, they had a 'glitch' on their server which tricked some systems into installing the rc for 5.7 before they fixed it.

- i would suggest removing 5.7

mangos doesn't currently support mysql above 5.6

Hello, I'm having this issue, I already uninstalled MySQL and reinstalled 5.6 ensuring I have the right version. I've also reinstalled Open SSL ,  VCR Redist, Visual Studio, anything else I can try? 

Link to post
Share on other sites
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use